quickaccess widget in panel does not respect panel icon size

Reported by Janet on 2010-09-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
QuickAccess
Undecided
Unassigned
plasma-widget-quickaccess (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: plasma-widget-quickaccess

Affects KDE SC 4.5: When I set the panel icons' size to max 48 or higher in systemsettings all application launcher and menu icons adjust to this size when the panel is dragged to be higher. Some special icons like trash, show dashboard, show desktop and the quickaccess widget don't respect/follow these settings, their icons in the panel stay at tiny 32x32 size even in panel with 128x128 icons. Looks odd and makes it hard to work with that widget.

As Kubuntu uses the quickaccess widget as panel default to display the content of the home folder I think this should be reported (and fixed?) here.

See Bug 193756 at bugs.kde.org and http://forum.kde.org/viewtopic.php?f=17&t=90090&p=169419#p169419

Changed in plasma-widget-quickaccess (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Janet (bugzilla-kerridis) wrote :

Thanks for confirming. I see that there are a lot more important things to do. But please keep in mind that there are people with not so good eyes. For them (like me) the importance is not "low". In KDE 4.4 I was forced to use small panel icons (something just below 48) but all had the same size. Now with 4.5 I finally can increase the panel icons to my preferred size of 80x80 - but that throws the quickaccess icons in the panel (yes, I use more than one for individual menus) to tiny size 32x32 (not 46 or 47 as in 4.4). So the situation got worse for this widget.

Janet (bugzilla-kerridis) wrote :

Patched quickaccess.h and quickaccess.cpp according to trash widget solution. Works for me, compiled successfully, quickaccess icons grow to panel size now.

Janet (bugzilla-kerridis) wrote :

and here is the diff for quickaccess.h

tags: added: patch
Janet (bugzilla-kerridis) wrote :

Already patched version is available at http://kde-look.org/content/show.php?content=134442

Janet (bugzilla-kerridis) wrote :

This is relevant for all KDE versions following 4.5. Will this finally be implemented in Natty Narwhal? It really is a pain to have such small quickaccess icons in the panel (usability + look).

Janet (bugzilla-kerridis) wrote :

Fixed in version 0.8.2 ! http://kde-look.org/content/show.php?content=134442
Compiles fine on KDE SC 4.6+
It "just" needs to be packaged for Kubuntu now.

Ahmed Shams (ashams) on 2011-11-18
summary: - quickaccess widget widget in panel does not respect panel icon size
+ quickaccess widget in panel does not respect panel icon size
Ahmed Shams (ashams) on 2011-11-18
Changed in quickaccess:
status: New → Fix Released
Changed in plasma-widget-quickaccess (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Timothy Arceri (t-fridey) wrote :

The package linked to this bug should be set to Fix committed not fix released

Changed in hundredpapercuts:
status: Confirmed → Fix Committed
milestone: none → quantal-11-misc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers