The default version of Ghostscript (9.10) on Ubuntu 14.04 does not allow the proper detection of corners

Bug #1328917 reported by Julien Chavant on 2014-06-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
queXF
Undecided
Adam Zammit

Bug Description

The default version of Ghostscript (9.10) on Ubuntu 14.04 x64 does not allow the proper detection of corners.
With the same questionnaire using Ghostscript 9.04 or 9.14, the edges are detected.

Thank you to all the QueXF team for this valuable work ;-)

Julien Chavant (julien-chavant) wrote :
Adam Zammit (adamzammit) wrote :

Dear Julien,

Thanks for your investigation.

Can you please run "Test form compatibility" using queXF with GS 9.10 - and then send me the resulting PNG image generated in the browser?

I should be able to use this to debug the issue in GS.

Regards,
Adam Zammit

Dear Adam,

Thanks for you reply and your attention.
Please find attached the images generated by Ghostscript (version 9.10
x64 and 9.14 x64). Hoping that this will serve and remain at your disposal.
Regards.

Julien.

Le 13/06/2014 07:47, Adam Zammit a écrit :
> Dear Julien,
>
> Thanks for your investigation.
>
> Can you please run "Test form compatibility" using queXF with GS 9.10 -
> and then send me the resulting PNG image generated in the browser?
>
> I should be able to use this to debug the issue in GS.
>
> Regards,
> Adam Zammit
>

--
Julien Chavant
Inserm - EPHE - Université de Caen Basse Normandie
Unité de Recherche U1077
"Neuropsychologie et Neuroanatomie Fonctionnelle de la Mémoire
Humaine"
Laboratoire de Neuropsychologie
CHU, Avenue de la Côte de Nacre
CS 30001
14033 - Caen cedex
Tel : +33231063261
Fax : +33231065198
émail: <email address hidden>
URL: www.u1077.caen.inserm.fr

Adam Zammit (adamzammit) on 2014-12-22
Changed in quexf:
status: New → Won't Fix
assignee: nobody → Adam Zammit (adamzammit)
Adam Zammit (adamzammit) wrote :

Thanks Julien for this and my apologies for the slow response.

The issue is an upstream one with Ghostscript.

The bug is reported here:

http://bugs.ghostscript.com/show_bug.cgi?id=695080

It was introduced in 9.10 and then corrected for 9.14

So GS 9.10 should not be used for queXF.

I haven't tried this PPA but it appears 9.14 is available here for Ubuntu trusty:

https://launchpad.net/~alvind/+archive/ubuntu/backports?field.series_filter=trusty

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.