JPA Test OutOfMemoryError

Bug #785520 reported by rrmckinley on 2011-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Querydsl
Fix Released
Undecided
Unassigned

Bug Description

There is probably something wrong with one of the tests that it would need so much memory. I had to set -Xmx higher in the surefire configuration to allow it to pass.

rrmckinley (rrmckinley) wrote :
rrmckinley (rrmckinley) wrote :

Which Maven version are you using?

I tried it with 3.0.2 and 3.0.3. This is on Mac OS with the latest Java update. I take it that you can't reproduce the problem? Is there anything else I should look for when this happens?

Cheers,

Rich

Sent from my phone.

On May 22, 2011, at 6:49 AM, Timo Westkämper <email address hidden> wrote:

> Which Maven version are you using?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/785520
>
> Title:
> JPA Test OutOfMemoryError
>
> Status in Querydsl:
> New
>
> Bug description:
> There is probably something wrong with one of the tests that it would
> need so much memory. I had to set -Xmx higher in the surefire
> configuration to allow it to pass.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/querydsl/+bug/785520/+subscribe

Vesa Marttila (ponzao) wrote :

I was not able to reproduce with Maven 3.0.2 and Linux 32bit.

Apache Maven 3.0.2 (r1056850; 2011-01-09 02:58:10+0200)
Java version: 1.6.0_24, vendor: Sun Microsystems Inc.
Java home: /usr/lib/jvm/java-6-sun-1.6.0.24/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "2.6.32-30-generic-pae", arch: "i386", family: "unix"

I am currently on holidays, but Vesa might be able to look into this.

Changed in querydsl:
status: New → In Progress

Fixed in SVN trunk

Sorry, fixed in Git master ;)

Changed in querydsl:
status: In Progress → Fix Committed

Released in 2.2.1

Changed in querydsl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers