There is no default java type mapping for float data type in MySQL

Bug #648484 reported by Luis Fernando Planella Gonzalez on 2010-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Querydsl
Fix Released
Medium
Unassigned

Bug Description

I have a database table with a float column in MySQL.
The problem is that Querydsl is generating the bean with an Object property on it.
For some reason, the MySQL driver reports the float column as type REAL, not FLOAT...
After adding configuration.setType(Types.REAL, Float.class), it worked fine.

Changed REAL type mapping from Object to Float

Changed in querydsl:
status: New → Fix Committed
importance: Undecided → Medium

Released in 2.0.0-beta-2

Changed in querydsl:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers