qtubuntu-sensors & Qt 5.2 - part 3, tests failing

Bug #1271886 reported by Timo Jyrinki on 2014-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtubuntu-sensors
High
Unassigned
qtubuntu-sensors (Ubuntu)
Undecided
Unassigned

Bug Description

After fixes to bug #1271034 and bug #1271415, next up are test failures in test_sensor_api:

https://launchpadlibrarian.net/163180314/buildlog_ubuntu-trusty-amd64.qtubuntu-sensors_1%3A0.6%2B14.04.20140113.1-0~47%2B201401201320~ubuntu14.04.1%2Bfixqt52~test2_FAILEDTOBUILD.txt.gz

To reproduce:
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta2
apt-get update
apt-get dist-upgrade
+
bzr bd

Related branches

Timo Jyrinki (timo-jyrinki) wrote :

Disabled the tests in a PPA build temporarily.

description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:qtubuntu-sensors at revision 49, scheduled for release in qtubuntu-sensors, milestone Unknown

Changed in qtubuntu-sensors:
status: New → Fix Committed
Changed in qtubuntu-sensors (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu-sensors - 0.6+14.04.20140213-0ubuntu1

---------------
qtubuntu-sensors (0.6+14.04.20140213-0ubuntu1) trusty; urgency=low

  [ Martin Pitt ]
  * Add integration tests for the QtSensor API → qtubuntu-sensors →
    platform-api (with simulated sensor backend).
  * Fix crash if there are no available sensors. (LP: #1272294)

  [ Albert Astals ]
  * Make it compile with Qt 5.2 (LP: #1271415). (LP: #1271415)
  * Q_ASSERT -> EXPECT_EQ Since sometimes Q_ASSERT can be compiled out
    and thus the test would fail. (LP: #1271886)
 -- Ubuntu daily release <email address hidden> Thu, 13 Feb 2014 01:44:53 +0000

Changed in qtubuntu-sensors (Ubuntu):
status: Fix Committed → Fix Released
Changed in qtubuntu-sensors:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers