Problem with special characters

Bug #127640 reported by Siegfried Gevatter on 2007-07-22
2
Affects Status Importance Assigned to Milestone
QtTube
Medium
Siegfried Gevatter

Bug Description

When you write a special character (for example, an accent) on any of the two above line edits (input boxes), the program gets responsive for some seconds and then displays a lot of strange (orient-language-like) characters. The "File Name" input works perfectly.

Changed in qttube:
importance: Undecided → Medium
status: New → Confirmed
Siegfried Gevatter (rainct) wrote :

Problem found, it isn't because of Qt but the custom functions that handle the input: Gui.urlChange() and Gui.idChange().

Changed in qttube:
assignee: nobody → rainct
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

Fixed. The problematic strings are now converted to ASCII (8-bit) before Python works with them. Some special characters work now there, others are converted to a interrogation mark "?", but since the fields are for URLs and not filenames nor nothing like this where they would be allowed it shouldn't be any problem.

Example of characters that...
 work: à é ç
 don't work: у л я р

Changed in qttube:
status: In Progress → Fix Committed
Changed in qttube:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers