[ubuntu] sixad daemon not starting at boot

Bug #778845 reported by Hassan Williamson on 2011-05-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QtSixA
Undecided
Unassigned

Bug Description

Distro: Ubuntu 10.10 (Maverick Meerkat).
Qt version: 4.7.0
PyQt version: 4.7.4
QtSixA version: 1.5.0

The problem I have is that on boot the sixad daemon doesn't sit and wait for a controller to be connected.

Sometimes I have to force it by doing "sudo /etc/init.d/sixad start" and then connect the controller up, but then the daemon is still sat running at the terminal. Although I've noticed doing CTRL+C to close it, the controller stays connected and will continue to work thereafter regardless of how many times I connect/disconnect it. Its just a pain that I have to start it up manually each time. Also doing it this way, I've noticed issuing "sudo /etc/init.d/sixad status" shows that its not running.

Using the main GUI "force" option from the menu doesn't accept connections either. So the only way for me is to do "sudo /etc/init.d/sixad start".

falkTX (falk-t-j) wrote :

hey there,

please try the git code:
git clone git://qtsixa.git.sourceforge.net/gitroot/qtsixa/qtsixa

tell me if it works

and btw, you should use "sixad [commands]" instead of /etc/init.d/sixad...

falkTX (falk-t-j) wrote :

please try the latest version, 1.5.1

Hassan Williamson (hazrpg) wrote :

I have updated, but I haven't had chance to try it yet. Will let you know as soon as I have.

Kirkulez (tokirkules) wrote :

I'm having roughly the same issue. I'm using 1.5.1 from source on Sabayon (gentoo).

I need to run sixad -s in a terminal in order to use it. When I use a terminal is asks for a password, if I use Autostart or Alt-F2 or anything else it does nothing.

I've noticed that make install-system is no longer in the makefiles even though it is still in the instructions. Could this be a permissions issue related to this?

falkTX (falk-t-j) wrote :

make install-system was removed and it's not needed anymore.
the gui should be ignored for now, it doesn't work right.

you do need to run 'sixad -s' from terminal, that's on purpose (the auto-connect feature stopped working on 2.6.37+ kernels)

'sixad --boot-yes' should make it start on boot. is this what is failing for you?

Hassan Williamson (hazrpg) wrote :

Hi there, I do apologise I didn't report back yet. I am using v1.5.1, and the gui still fails to auto-connect the controller. Seems on boot I still have to issue either "sudo /etc/init.d/sixad start" or "sixad -s" to get this to work.

I haven't tried "sixad --boot-yes" yet, but will give that a try. Have you figured out why it doesn't just do this automatically? Considering it does have an upstart job...

Will report back in a moment once I've rebooted to see if "sixad --boot-yes" fixes this... might be worth changing the gui to run this command maybe if it does? (just food for though...)

Hassan Williamson (hazrpg) wrote :

As promised, tried rebooting several times. Used "sixad --boot-yes" and no success. Only way for it to work was using "sixad -s". Although this is bothersome, its easy to live with since I don't use it every day anyways. It would just be nice for it to work from the offset. Since I know some people that find it a hassle to do all the time (people I've recommended this software to, that aren't nessisarily technially minded - but love ubuntu). I've made a script for those guys, since its the only way for them to understand.

Look forward to your future updates, and hope one day it'll be included into the main repo (or even better, straight into the kernel!).

Kirkulez (tokirkules) wrote :

I also tried "sixad --boot-yes" which adds it to runlevel default but doesn't actually fix anything.

Instead I added this command: "echo MyPassword|sudo -S sixad -s" in my 'Autostart' configuration in KDE.

It's not ideal but for now it lets my less knowledgeable friends use my controllers without the extra step in a terminal.

Hassan Williamson (hazrpg) wrote :

Not sure if this is relevant anymore since Ubuntu 16.04 supports both the Sixaxis and DualShock 3 controllers out of the box - seems to be able to pair them correctly too. I have even tested DualShock 4 controllers.

Just wondering, but has QtSixA been retired due to the (seemingly) native support? I still liked the interface for being able to configure my controllers - and it would be nice if there was a GUI for joysticks/controllers that looked nice and worked really well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers