Controllers connect but no input is received.

Bug #1045097 reported by Martin Hovmöller on 2012-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QtSixA
Undecided
Unassigned

Bug Description

I have two PS3 controllers, one Sixaxis and one Dual Shock 3, connected to my Debian wheezy box running sixad.
Sometimes everything works perfectly, but probably 80% of the times I try to connect one of the controllers, or both, the controller connects but no input is received from it.
Running jstest /dev/input/js0 or js1 just gives me a lot of empty values that stay still when I press buttons on the controller.

I'm running sixad version 1.5.1.

Foul (foulweb) wrote :

Exactly the same !

Kubuntu 13.04 64 Bits on 2 differents PC

Here is my Bluetooth key :

Bus 005 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

pasqui (p3dimaria) wrote :
Download full text (15.9 KiB)

The same on my Linux Mint 17 amd64(linux-image-generic version 3.13.0-24.46,but the problem present itself also with version 3.13.0-24.47),with dualshock 3 connected via USB.

Here the output of jstest /dev/input/js0

Driver version is 2.1.0.
Joystick (Sony PLAYSTATION(R)3 Controller) has 27 axes (X, Y, Z, Rz, (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null), (null))
and 19 buttons (Trigger, ThumbBtn, ThumbBtn2, TopBtn, TopBtn2, PinkieBtn, BaseBtn, BaseBtn2, BaseBtn3, BaseBtn4, BaseBtn5, BaseBtn6, BtnDead, BtnA, BtnB, BtnC, (null), (null), (null)).
Testing ... (interrupt to exit)
Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: 0 13: 0 14: 0 15: 0 16: 0 17: 0 18: 0 19: 0 20: 0 21: 0 22: 0 23: 0 24: 0 25: 0 26: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7Axes: 0: 0 1: 0 2: 0 3: 0 4: 0 5: 0 6: 0 7: 0 8: 0 9: 0 10: 0 11: 0 12: ...

gbajson (gbajson) wrote :

I have the same problem on:

Linux misio 3.2.0-4-amd64 #1 SMP Debian 3.2.63-2 x86_64 GNU/Linux

Bus 001 Device 034: ID 054c:0268 Sony Corp. Batoh Device / PlayStation 3 Controller
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 64
  idVendor 0x054c Sony Corp.
  idProduct 0x0268 Batoh Device / PlayStation 3 Controller
  bcdDevice 1.00
  iManufacturer 1
  iProduct 2
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 41
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0x80
      (Bus Powered)
    MaxPower 500mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 0 No Subclass
      bInterfaceProtocol 0 None
      iInterface 0

Regards,
gbajson

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers