[SRU] Scopes support depends on Unity8 and other non desktop packages

Bug #1304548 reported by Pat McGowan on 2014-04-08
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity 8
Trusty
In Progress
Undecided
Unassigned
qtcreator-plugin-ubuntu
Invalid
Undecided
Unassigned
unity8 (Ubuntu)
Medium
Michał Sawicz

Bug Description

installing ubuntu-sdk now also installs unity8, touch system-settings, the touch nework-indicator, etc

The following extra packages will be installed:
  account-plugin-ubuntuone indicator-network qtcreator-plugin-ubuntu
  ubuntu-system-settings ubuntu-system-settings-online-accounts
  unity-scope-click unity-scope-tool unity8
Suggested packages:
  click-reviewers-tools
The following NEW packages will be installed:
  account-plugin-ubuntuone indicator-network qtcreator-plugin-ubuntu
  ubuntu-sdk ubuntu-system-settings ubuntu-system-settings-online-accounts
  unity-scope-click unity-scope-tool unity8

Are all these really required?

[Test Case]
Install ubuntu-sdk. See that unity8 is pulled with the above dependencies. The fix splits out a unity8-common package containing files needed by unity-scope-tool, reducing the need for installing the whole of unity8 and its dependencies.

[Regression Potential]
If there's a missing file on which unity-scope-tool depends on, undefined behaviour may affect in the application.

Related branches

Changed in qtcreator-plugin-ubuntu:
status: New → Confirmed
David Planella (dpm) wrote :

On a conversation on IRC, pstolowski mentioned that he'd had a look at it, and that unity-scopes-tools depend on a bunch of QML files included with unity8.

The suggested course of action was to assess if these can be extracted into a separate package, and I believe pstolowski is following up with Saviq on that.

Changed in unity8:
assignee: nobody → Pawel Stolowski (stolowski)
Michał Sawicz (saviq) on 2014-04-22
Changed in unity8:
status: New → In Progress
Changed in unity8 (Ubuntu):
status: New → In Progress
Changed in qtcreator-plugin-ubuntu:
status: Confirmed → Invalid
Michał Sawicz (saviq) on 2014-04-24
Changed in unity8:
importance: Undecided → Medium
assignee: Pawel Stolowski (stolowski) → Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
assignee: nobody → Michał Sawicz (saviq)

I noticed that this bug should be resolved for Utopic since the newest Unity 8 has been splitted (unity8-common).

https://launchpad.net/ubuntu/utopic/+source/unity8/7.86+14.10.20140429.2-0ubuntu1

I wonder when and if the same change will land in Trusty. I can't update several packages because of this bug (Mesa and of course qtcreator-plugin-ubuntu). If check only Mesa to update I get a huge list of packages to be removed and when I check everything to update I of course still get all these Unity 8 packages to install.

Unity 8 in Trusty on desktop is useless so I'm not going to install that and on top of that it removes modemmanager. Removing modemanager means that anyone using modem with NetworkManager can't connect to internet. There are of course other programs like Wvdial (which I'm using) but that isn't part of default install.

Michał Sawicz (saviq) wrote :

Where are you trying to update from? Distro should not have the issues you described, but we'll SRU this split to trusty nevertheless.

Changed in unity8:
status: In Progress → Fix Released
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2014-05-02
summary: - Scopes support depends on Unity8 and other non desktop packages
+ [SRU] Scopes support depends on Unity8 and other non desktop packages
Michał Sawicz (saviq) on 2014-05-02
description: updated
tags: added: scope-dev
Michał Sawicz (saviq) on 2017-03-13
Changed in unity8 (Ubuntu):
importance: Undecided → Medium
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers