Qt

unity-2d-panel crashed with SIGSEGV

Bug #843432 reported by nutznboltz on 2011-09-07
112
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Qt
Undecided
auto-samuel.rodal
Unity
Invalid
Undecided
Unassigned
unity-2d
Critical
Alberto Mardegan
meta-gnome2 (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Critical
Unassigned

Bug Description

1. Build qemu-kvm in 32-bit mode (x86) virtual machine on Sept 2, 2011
2. install from ubuntu-11.10-beta1-desktop-i386.iso
3. reboot from hard disk, unity panel with no icons visible will flash on and off a few times then stop trying.
4. apply updates on Sept 2, 2011
5. reboot from hard disk, unity panel with no icons visible will flash on and off a few times then stop trying.
6. report that as LP: #839585
7. apply updates again on on Sept 5, 2011
8. reboot from hard disk, unity panel with no icons visible will flash on and off a few times then stop trying.
9. apply updates again on on Sept 6, 2011
A. reboot from hard disk, unity panel works for a few seconds and then crashes, this time Apport dialog appears, click "report problem"
B. fiddle about with panel and get a different crash ``Sorry, the program "unity-2d-spread" closed unexpected.
C. Click on Apport and it creates LP: #843448

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity-2d-panel 4.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
Architecture: i386
CrashCounter: 1
Date: Tue Sep 6 20:55:28 2011
Disassembly: => 0x996b06: Cannot access memory at address 0x996b06
ExecutablePath: /usr/bin/unity-2d-panel
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
ProcCmdline: unity-2d-panel
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x996b06: Cannot access memory at address 0x996b06
 PC (0x00996b06) ok
 SP (0xbfa88808) ok
 Reason could not be automatically determined.
Signal: 11
SourcePackage: unity-2d
Stacktrace:
 #0 0x00996b06 in ?? ()
 No symbol table info available.
 #1 0x00000000 in ?? ()
 No symbol table info available.
StacktraceTop:
 ?? ()
 ?? ()
Title: unity-2d-panel crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Stacktrace:
 #0 0x00996b06 in ?? ()
 No symbol table info available.
 #1 0x00000000 in ?? ()
 No symbol table info available.
StacktraceTop:
 ?? ()
 ?? ()

Changed in unity-2d (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

outdated debug symbol package for libavahi-common3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for libtiff4: package version 3.9.5-1ubuntu1 dbgsym version 3.9.4-5ubuntu6
outdated debug symbol package for libnih1: package version 1.0.3-4ubuntu2 dbgsym version 1.0.3-1ubuntu1
outdated debug symbol package for dpkg: package version 1.16.0.3ubuntu3 dbgsym version 1.16.0~ubuntu7.1
outdated debug symbol package for libgpg-error0: package version 1.10-0.3ubuntu1 dbgsym version 1.10-0.2ubuntu1
outdated debug symbol package for psmisc: package version 22.14-1 dbgsym version 22.13-1
outdated debug symbol package for libk5crypto3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for libavahi-client3: package version 0.6.30-4ubuntu1 dbgsym version 0.6.30-0ubuntu2
outdated debug symbol package for passwd: package version 1:4.1.4.2+svn3283-3ubuntu2 dbgsym version 1:4.1.4.2+svn3283-3ubuntu1
outdated debug symbol package for libkrb5-3: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for libdatrie1: package version 0.2.4-3 dbgsym version 0.2.4-1
outdated debug symbol package for libslang2: package version 2.2.4-2ubuntu1 dbgsym version 2.2.2-4ubuntu2
outdated debug symbol package for libgssapi-krb5-2: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for libstartup-notification0: package version 0.12-1 dbgsym version 0.10-1build1
outdated debug symbol package for procps: package version 1:3.2.8-10ubuntu5 dbgsym version 1:3.2.8-10ubuntu3
outdated debug symbol package for libkrb5support0: package version 1.9.1+dfsg-1ubuntu1 dbgsym version 1.8.3+dfsg-5ubuntu2.1
outdated debug symbol package for libnih-dbus1: package version 1.0.3-4ubuntu2 dbgsym version 1.0.3-1ubuntu1
outdated debug symbol package for libthai0: package version 0.1.15-2 dbgsym version 0.1.14-2ubuntu1
outdated debug symbol package for module-init-tools: package version 3.16-1ubuntu1 dbgsym version 3.12-1ubuntu6
outdated debug symbol package for libltdl7: package version 2.4-2ubuntu1 dbgsym version 2.2.6b-2ubuntu3

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace

Updating via "apt-get update" "apt-get upgrade" did nothing because I had done that already about 10 minutes before opening this bug.

ran xdpyinfo > xdpyinfo.txt

This bug is really a continuation of LP: #839585 after the bug changed after an update.
The KVM guest is the same one with only changes made by APT updates.

description: updated
description: updated
visibility: private → public
description: updated
maninred (maninred) wrote :

Itś nothing about flashing on my system, but there is just a crash near on startup.

maninred (maninred) on 2011-09-14
Changed in unity-2d (Ubuntu):
status: Invalid → Confirmed

Some definitions for outsiders:

unity-2d-panel is (some of) the strip across the top of the display
unity-2d-launcher is the dock on the left side of the screen
unity-2d-spread is the workspace switcher

tags: added: 24bit

If you just want a quick work-around to this:

In /etc/lightdm/lightdm.conf append

xserver-command=X -depth 16

use a space before the dash and no quotes. Then reboot into 16bit X mode (65,536 colors) and this bug will no longer affect you.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in meta-gnome2 (Ubuntu):
status: New → Confirmed
Changed in meta-gnome2 (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: New → Invalid
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
importance: Undecided → Critical
Changed in unity-2d:
importance: Undecided → Critical
Alberto Mardegan (mardy) on 2011-09-29
Changed in unity-2d:
status: Confirmed → In Progress
assignee: nobody → Alberto Mardegan (mardy)
milestone: none → 4.14
milestone: 4.14 → 4.12
Changed in unity-2d:
status: In Progress → Fix Committed

I just applied updates, see below for some details. I'm not sure if they included the fix that was provided for this ticket or not.

Now the unity-2d-panel still does not display and also plymouthd just crashed. I'm going to let apport open another ticket.

$ grep "status installed" /var/log/dpkg.log | grep unity
2011-09-27 20:49:43 status installed libunity6 4.0.6-0ubuntu1
2011-09-27 20:50:37 status installed gir1.2-unity-4.0 4.0.6-0ubuntu1
2011-09-27 20:50:41 status installed unity-services 4.18.0-0ubuntu1
2011-09-27 20:50:41 status installed libunity-core-4.0-4 4.18.0-0ubuntu1
2011-09-27 20:50:41 status installed unity-common 4.18.0-0ubuntu1
2011-09-27 20:51:38 status installed unity-greeter 0.1.0-0ubuntu1
2011-09-27 20:51:38 status installed unity-lens-applications 0.4.10-0ubuntu1
2011-09-27 20:51:38 status installed unity-lens-files 0.6.8-0ubuntu1
2011-09-27 20:51:50 status installed libunity-2d-private0 4.10.0-0ubuntu1
2011-09-27 20:51:50 status installed unity-2d-spread 4.10.0-0ubuntu1
2011-09-27 20:51:50 status installed unity-2d-places 4.10.0-0ubuntu1
2011-09-27 20:51:50 status installed unity-2d-panel 4.10.0-0ubuntu1
2011-09-27 20:51:51 status installed unity-2d-launcher 4.10.0-0ubuntu1
2011-09-27 20:51:51 status installed unity-2d 4.10.0-0ubuntu1
2011-09-29 09:45:43 status installed libunity6 4.0.6-0ubuntu2
2011-09-29 09:45:43 status installed gir1.2-unity-4.0 4.0.6-0ubuntu2
2011-09-29 09:46:32 status installed unity-greeter 0.1.1-0ubuntu1
2011-09-29 09:46:32 status installed unity-lens-applications 0.4.10-0ubuntu2
2011-09-29 09:46:33 status installed unity-lens-music 0.2.4-0ubuntu1
2011-09-29 09:46:34 status installed unity-scope-musicstores 0.2.4-0ubuntu1

The new bug report with the plymouthd crash is LP: #862421

Michał Sawicz (saviq) wrote :

@nutznboltz nope, the fix is not yet released, and it will be in qt4-x11, not in unity-2d itself.

Didier Roche (didrocks) on 2011-09-29
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.12.0-0ubuntu1

---------------
unity-2d (4.12.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel assert failure: *** glibc detected *** unity-2d-panel:
      malloc(): smallbin double linked list corrupted: 0x08313b28 ***
      (LP: #845979)
    - unity-2d-panel assert failure: *** glibc detected *** unity-2d-panel:
      corrupted double-linked list: 0x094bc9b0 *** (LP: #852012)
    - unity-2d-panel crashed with SIGSEGV (LP: #843432)
    - Dragging downwards from the menu bar or double clicking on the menu bar
      should un-maximise the window (LP: #661049)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - [dash] Do search, scroll down using mouse, then maximise window. Layout
      breaks (LP: #817421)
    - F10 doesn't start keyboard navigation to the panel (LP: #839628)
    - [dash] Gridview moves to top when you open or close the "Show X more.."
      dropdown or the Filter pane (LP: #850036)
    - Impossible to navigate between panel menus when the mouse cursor is over
      the panel (LP: #834065)
    - [panel] F10 menu initially shown about half screen down (LP: #853766)
    - [dash] Filter pane doesn't clear its background when switching lenses
      (LP: #858590)
    - [shortcuts] <Super><Shift># should launch a new instance of #
      application (LP: #768006)
    - unity-2d-spread missing background images when path includes Unicode
      (LP: #855508)
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 16:58:34 +0200

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released

Awesome! You ROCK!

The unity-2d-panel and unity-2d-spread are both working correctly now. :)

Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-samuel.rodal Edit

Bug watches keep track of this bug in other bug trackers.