Recordmydesktop has exited with status 768

Bug #208139 reported by Fabio Colombo on 2008-03-28
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gtk-recordmydesktop (Ubuntu)

Bug Description

Binary package hint: gtk-recordmydesktop

Tesing Hardy, on 386 i obtain this:

blackdiamond@blackdiamond-desktop:~$ recordmydesktop
Initial recording window is set to:
X:0 Y:0 Width:1280 Height:768
Adjusted recording window is set to:
X:0 Y:0 Width:1280 Height:768
Your window manager appears to be Metacity

Buffer size adjusted to 4096 from 4096 frames.
Couldn't open PCM device hw:0,0
Error while opening/configuring soundcard hw:0,0
Try running with the --no-sound or specify a correct device.

The same thing happens with the graphical version..

i continue to have this and i can't solve.. solution?
so is a problem of my soundcard or something like that? or you think that is a bug?


markba (mark-baaijens) wrote :

If you disable sound (do not record sound) by remove the checkmark before label 'Sound Quality', you will be able to record video info, though, obviously, without any sound recorded. So this has something to do with the sound settings.

markba (mark-baaijens) wrote :

When you do this:

1.) Open up a terminal & type "gnome-volume-control"
2.) Edit -> Preferences
3.) Check "capture"
4.) A "recording" tab should pop up. Click on that, slide the volume up if it's set to zero and click the microphone icon so that it doesn't have a red "x" through it
5.) Try RecordMyDesktop again. With any luck it should be working.

It starts without an error, but nonetheless, again no sound.

According to:

Daniel T Chen (crimsun) wrote :

If you are using pulseaudio, you will need to use: pasuspender -- /usr/bin/gtk-recordMyDesktop

Changed in gtk-recordmydesktop:
status: New → Invalid
azhallaoui (azhallaoui) wrote :

I removed the gtk-recordmydesktop directory from my home directory and reinstall the gtk-recordmydesktop and it works for me again.
sudo rm -r /home/hijra810/.gtk-recordmydesktop

suniyo (suniyo) wrote :

it is working but video/audio is still out of sync. anyone found any solution to this? there is this one I found here: and testing it right now if it works for me.

suniyo (suniyo) wrote :

Solution worked for me with certain settings but still it is not perfect and quality is low with large file sizes. I have around 4 minute video (1152x864) in .ogv format with filesize 45 mb that is too much. When I convert it to .avi with -sameq applied to it in ffmpeg the resulting .avi file is around 150mb !! When I reduce some quality and make it 320x240 size it still results in 6mb file. So this solution is still not ideal or perfect for everyone including me.

manolo (mac-man2005) wrote :

I get this error:

"record mydesktop has exited with status: 768"

and I'd like to always record sound too, not just everynow and then. Any suggestion, please? Thanks.

Martin Pihl (pihl) wrote :

I have this problem as well.

Using "pasuspender -- /usr/bin/gtk-recordMyDesktop" as suggested removes the error alright, but also sound, unfortunately.

So this is really not a solution if you need to record sound as I do.

recordMyDesktop works fine for me until I start Virtualbox and a VM. It's not until then I get the error message from this bug report, and nothing of it's kind before starting the VM.

achu (achumesfin) wrote :

1. Click the Advanced button
2. Select the sound-tab
3. In "Device" change "DEFAULT" to "default"
4. It works!

MilezWalker (shi88ihs) wrote :

 I second: achu (achumesfin) - above. ^


 SOLVED for ME!!

 "1. Click the Advanced button
   2. Select the sound-tab
   3. In "Device" change "DEFAULT" to "default"
   4. It works!"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers