Search skips results when in "Continuous View"

Bug #1851097 reported by Spyros Papanastasiou on 2019-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qpdfview
Undecided
Unassigned

Bug Description

OS: Gentoo
qpdfview: 0.4.16, 0.4.18_pre4

Search works fine in single page view, but when switching to "Continuous Mode", it usually jumps to the first result after the first result of the second page. I had results been highlighted.

No, sorry. It seems to be specific to my system. I tested it in another PC and it worked fine. With the same pdfs. Please remove this report.

Changed in qpdfview:
status: New → Invalid

Fixed it by recompiling its dependency, qtcore, with "-fno-fast-math", since i had compiled it with "-Ofast":P.

Adam Reichold (adamreichold) wrote :

Hello Spyros,

thank you for taking the time to report this! Indeed Poppler does internally track search results using their bounding boxes the coordinates of which are floating point, so `-Ofast` could have the effect you described. Glad that you were able to figure this out!

Best regards,
Adam

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers