Prints whole file instead of selected page(s)

Bug #1825094 reported by Terrance
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Adam Reichold

Bug Description

Print, select "Pages" to "1" to print page 1 only, results printing whole file.

addition info:
Printing "Current pages" works fine.

This version includes:
PDF support using Poppler 0.68.0
PS support using libspectre 0.2.8
DjVu support using DjVuLibre 3.5.27
Printing support using CUPS 2.2.8

Tags: print
Revision history for this message
Adam Reichold (adamreichold) wrote :

Hello Terrance,

thank you for taking the time to report this. We did have that bug of overwriting the "page-ranges" CUPS option that Qt's print dialog sets (after it acquired that functionality recently) but it should be fixed since November 2018:

revno: 2086
committer: Adam Reichold <email address hidden>
branch nick: trunk
timestamp: Thu 2018-11-22 14:27:05 +0100
  Do not overwrite page-ranges CUPS option when it was already set by Qt's print dialog.

Can you make sure that you are using a build based on at least trunk revision 2086? Can you reproduce this when building from source or using the dailydeb from [1]? (I tried it locally running OpenSUSE Tumbleweed and failed to reproduce the issue using the current trunk.)

Best regards,


Changed in qpdfview:
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Adam Reichold (adamreichold)
Revision history for this message
Clay Spence (clayorama) wrote :

I had the same problem with the version distributed with Lubuntu 19.04. But when I upgraded as described above, to, which seems to give "qpdfview 0.4.18beta1" in the "About" window, the problem went away.

Revision history for this message
kike (kikecalpe) wrote :

I also have the same problem with qpdfview 0.4.18beta1.
I tried different printers with same result.

Revision history for this message
Adam Reichold (adamreichold) wrote :

@kike Could you also give the dailydebs a try? My guess that the distributions have started packaging snapshots since I have a hard time actually getting a release out the door...

Revision history for this message
kike (kikecalpe) wrote :

@AdamReichold I've installed and it looks it is printing as expected.
Thank you!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.