add buttons for annotation/text selection actions

Bug #1028290 reported by Amit Keret on 2012-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qpdfview
Wishlist
Adam Reichold

Bug Description

This is more of a feature request:

Currently, as far as I can see, the only way to select text for copying and to add annotations is through the combination of keyboard key + dragging the cursor over an area.
I think it would be very handy to have buttons, one for annotations and one for text selection, that trigger the exact same action as the keyboard keys: Once a button is pressed, the programs "waits" for a rectangle to be drawn and executes the corresponding action on that rectangle, whether it be annotation of copying to clipboard.
I imagine the buttons behaving much like the "Format brush" from MS's Word: it triggers a "one-time" action waiting to happen at the next mouse-drag, and then they go on standby again.

This is for people (like me...) that don't use these features often, and then it takes them quite some time to go through Help contents and realize how to do it through keyboard shortcuts... a button would be very useful in this case.

Benjamin Eltzner (b-eltzner) wrote :

Hi Amit, I agree that the current state is less than optimal. I am rather undecided whether one-time buttons or (a) switch button(s) would be the better alternative but I would certainly not disregard accessibility of these features through the toolbar. However, it may be reasonable to not activate this/these button(s) by default but supply them as optional item(s) to the toolbar.

Changed in qpdfview:
importance: Undecided → Wishlist
Adam Reichold (adamreichold) wrote :

Even though I do really like the way it is currently implemented because it does not clutter the interface with yet another tool, I think this should be discussed for an upcoming release. The mailing list accessible at "https://launchpad.net/~qpdfview" would probably be a good place to do so.

Changed in qpdfview:
status: New → Triaged
Changed in qpdfview:
status: Triaged → In Progress
assignee: nobody → Adam Reichold (adamreichold)
milestone: none → 0.3.3
Adam Reichold (adamreichold) wrote :

Ok, this should now be possible via two new entries in the "edit" menu which are also available as tool bar actions named "copyToClipboard" and "addAnnotation" which initiate waiting for dragging a rubber band in a one-shot fashion.

Please test and report your results here. Thanks!

(There seems to be at least one problem/bug with this: If you start to drag and then do not activate a menu item and then start again, the mouse cursor will not change immediately... Don't know what to do about it yet...)

Changed in qpdfview:
status: In Progress → Fix Committed
Benjamin Eltzner (b-eltzner) wrote :

I did some testing with the buttons and so far I have not encountered any problems or unexpected behaviour in the current trunk version. So from my point of view, everything seems to work well. (I can reproduce the problem Adam describes, but it seems rather cosmetic to me, so I don't care much.)

Changed in qpdfview:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers