After latest improvements, now qpdfview doesn't remember the last scale when opening a new document

Bug #1024398 reported by Pascual Lucero on 2012-07-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qpdfview
Medium
Adam Reichold

Bug Description

Hello,

I had reported a small bug when the scaleFactor button was removed from the view Bar; in todays (July 12) version I see this fixed, but now I see a new problem.

In my case, for example, I like to open new documents with the "Fit to Page" scale. Until very recently, everything was working fine, but the last couple of days, it seems that this setting is not remembered anymore, because now new documents open at 100%.

Curiously, yesterday, using the 0.3.1.99-415 version, the size settings were remembered if the scaleFactor button was in the view Bar. If not, then size was not remembered. Now, using the 0.3.1.99-425 version, size settings are not remembered regardless if that button is in the view bar or not. I tried to uncheck to avoid viewing the view bar, in case that would help, but nothing. So, it is a recently introduced error, product of the latest changes.

Changed in qpdfview:
importance: Undecided → Medium
assignee: nobody → Adam Reichold (adamreichold)
status: New → Incomplete
Adam Reichold (adamreichold) wrote :

Hello,

So I guess it was not just improvements, was it? :-)

There was a problem with restoring the settings that was introduced in trunk revision 414 where settings handling was moved out of the DocumentView (to make it more useful as a component, e.g. for use in a plug-in). It should be unrelated to the visibility of the scale factor widget and affect all per-tab settings.

The problem should have been fixed with trunk revision 426, so can you please test a revision later than that report your findings? Thanks.

Regards, Adam.

Changed in qpdfview:
milestone: none → 0.3.2
Pascual Lucero (sacolevas) wrote :

Thanks, I use qpdfview everyday and check every night the latest trunk, so I will let you know if something was missing.

And thanks for your really quick answer, I entered just because I wanted to add something to this topic.

I think it would be elegant and normal (said normal thinking in lots of viewers I have used) that the default scale factor can be an option in the settings. So, a button like the scaleFactor that appear when I go to Settings, in which I choose my default settings for opening documents.

Of course, in the future, I don't know, the scale factor settings (and current page) could be remembered for each document in the "history", but for now, simply to put an option to set default scale in the settings.

Benjamin Eltzner (b-eltzner) wrote :

If everything works as intended, the default settings are always the latest settings set for a document. I consider this transparent and reproducible behaviour of the program. As it is one of the prime project goals to keep the code of qpdfview as simple and small as possible, I would not consider adding menu options to set a default manually a very urgent issue. I would suggest discussing this point via the mailing list, however I am not very fond of the idea.

Benjamin Eltzner (b-eltzner) wrote :

Hi Pascual, if the original problem (concernin scaling) is solved by the current version, I would like to mark this bug as "fix released". As already suggested above, I would like to defer follow up discussion on your later point to the mailing list. Could you give me your heads up, if the bug is fixed?

Pascual Lucero (sacolevas) wrote :

Hello,

The bug is fixed in the current version. Thanks :)

Changed in qpdfview:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers