using --unique switch causes loss of focus

Bug #1023538 reported by Amit Keret on 2012-07-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qpdfview
Medium
Adam Reichold

Bug Description

As per your suggestion, I've started using the --unique switch to open qpdfview, since I'd rather have only one instance of the program with multiple tabs.

However, since then I've noticed an undesired effect: When opening the 2nd PDF, the qpdfview window doesn't take focus. So the new PDF file is being opened, but if the window is "behind" another window, it stays in the background.

Just to clarify, this works properly when NOT using the --unique switch - obviously, the newly created window gets the focus.

(I'm filing this as a bug, since I'm pretty sure this wasn't the intended behavior...)

Adam Reichold (adamreichold) wrote :

Thanks for reporting. The fix is trunk revision 415 which is now raised and activated upon being requested to process a file via the "--unique" command-line option. Testing (e.g. via the daily debs) is appreciated.

Changed in qpdfview:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Adam Reichold (adamreichold)
Changed in qpdfview:
milestone: none → 0.3.2
Changed in qpdfview:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers