Disappearing panels

Bug #392294 reported by Michael Hall on 2009-06-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Qimo
High
Michael Hall

Bug Description

Top and Bottom panels disappear for unknown reasons.

Michael Hall (mhall119) wrote :

You can relaunch the panels by following these intructions:

1.) Press Alt+F2 to bring up the "Run Program" dialog.

2.) Type "xfce4-panel" without the quotes, and click the "Run" button.

That's it, your top panel and bottom launcher have been restored.

Another user (c3166925) wrote :

This is not working for me. Perhaps there is a log I can review to see why?

Once I've deleted the quick-launcher from the panel, this does not bring it back. The bottom launcher needs to be permanent so children using the computer can't remove it

Michael Hall (mhall119) wrote :

If you remove the quick-launcher from the panel, you will have to restore the /home/qimo directory from the CD

Michael Hall (mhall119) wrote :

The bug that caused the panel to disappear without user action is fixed in the newer Xfce that comes with Qimo 2.0. If you manually delete the panel or launchers in Qimo 2.0, you just have to delete the ~/.qimo directory to get the original configuration back.

Changed in qimo:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → mhall119 (mhall119)
Katie Eldridge (nailerscottage) wrote :

This has happened to me in Qimo 2.0

Installed fine, there when I rebooted, but then when switched off and switched back on again it failed to appear. Wallpaper lost the characters at the same time, so at first thought it had frozen part-way through loading - just after the login screen.

The manual Alt+F2 then typing xfce4-panel worked for me - still don't have the foreground of the wallpaper and I don't seem to be able to change this using the desktop settings application - it claims to be the default image with qimo and illa.

NB cannot be certain that this isn't fixed by an update, as the computer isn't generally connected to the internet, and on my first attempt at installing I tried to do the updates with an internet connection and it froze whilst applying them :(

Fairly new to linux, so please let me know if I have to look at something to give you more details to help see what happened or why.

Michael Hall (mhall119) wrote :

Katie,
    It sounds like multiple components are failing to load for you. The easiest solution is to delete ~/.qimo (the .qimo directory under your user's Home folder), then log out and back in again, this should reset everything to the default values.

Katie Eldridge (nailerscottage) wrote :

Thanks for your reply.

Meanwhile I searched further and tried Alt+F2 then xfdesktop, and my wallpaper was restored :)

Incidentally, this seems to have cured all the other 'problems' I was having with the system: it now boots up much faster, and I am able to add new users etc (before the plus button to add a new user was grayed out).

Thanks again - my toddler is delighted!

late to this sorry, but i've hit the same issue, no menu bar or quick-launch on boot up, running xfce4-panel brings them back, but i have to do this every time the computer is turned on, which is a huge pita of course. how can get this command to run automatically, or fix the root cause of the problem? I don't really want to delete my ~/.qimo folder since i already spend time added custom launchers to the quick launch bar and i want to create them all again. Is deleting that folder safe or is there another way?

Answered my own question - it was as simple as pressing 'logout' and making sure 'Save session' checkbox is ticked, and choose 'restart'. now it boots and panels are displayed correctly.

Link: http://www.qimo4kids.com/2009/04/have-questions/#comment-106

QIMO is awesome, thank-you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers