screendump broken for text mode

Reported by Avg on 2011-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

I use Qemu 0.15.0 (via a FreeBSD qemu-devel-0.15.0 port) and observe the following
problem with the screendump command.

Environment:
- qemu started with a standard vga adapter emulation (not sure if this important)
- SDL interface is used (not sure if this important)
- guest operating system uses the text mode
- monitor console is activated with Ctrl+Alt+2
- screendump command is executed in the monitor console

I observe the following effects in this case:
- contents of the guest screen is "dumped" over the monitoring console
- produced ppm file has only a single top-most line (of characters) from the guest
screen

It seems that the problem is caused in the vga_draw_text function in hw/vga.c.
The problem is that the dpy_update function is called for each line of text and
only the first of such calls produces the ppm output.

Perhaps in the case when full_update is true there should only be a single
dpy_update call for the whole screen. I think that this should produce a complete
screen dump. Not sure if that would help with the guest screen contents being
draw over the monitor console.

The code seems to be unchanged in the latest git version.

Cole Robinson (crobinso) wrote :
Changed in qemu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers