UHCI fails to signal stall response

Bug #757654 reported by Jan Vesely on 2011-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

When TD execution results in STALL error (STALL handshake, no stall as a result of err count reaching 0), there is no way to know about it except for checking that TD. IMO it is an error condition and it should be reflected in the status register (and issue an interrupt if enabled).

Ways to replicate:
Send a query that is answered by stall (like set_idle request to a mouse)

Expected behavior:
UHCI hc sets status bit 1 (usb error interrupt) and issues an interrupt

current behavior:
Neither status bit is set nor interrupt triggered

Version 0.14
attached patch for current master (quick fix, it might be I got something wrong)

Jan Vesely (jan.vesely) wrote :
Brad Hards (bradh) wrote :

Hi,

Thanks for reporting this issue.

Just so you are aware: the qemu USB maintainer is probably going to be away for a while longer, so don't be too worried if this patch doesn't get looked at for 2-4 weeks.

Brad

Jan Vesely (jan.vesely) wrote :

No problem, it's not like it breaks something. This fix just makes driver development easier.

On Thu, Apr 14, 2011 at 11:35 AM, jvesely <email address hidden> wrote:
> No problem, it's not like it breaks something. This fix just makes
> driver development easier.

Please send your patch to the mailing list:

http://wiki.qemu.org/Contribute/SubmitAPatch

It may seem petty to ask this since you've already attached it to the
bug, but for QEMU development to scale and keep at a rapid pace,
everyone needs to follow these steps on submitting patches. Thanks
for your effort!

Stefan

Thomas Huth (th-huth) wrote :

Patch had been included here:
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=8656954aedbd9995e68e
... so closing this ticket now.

Changed in qemu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers