system_powerdown NOT working in qemu-kvm with KVM enabled for FreeBSD guests

Bug #643430 reported by Andrey Golovizin on 2010-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned
Debian
New
Undecided
Unassigned

Bug Description

system_powerdown stops working in qemu-kvm for FreeBSD guests if KVM is enabled.

How to reproduce:

1. qemu -cdrom ~/.VirtualBox/libvirt/FreeBSD-8.1-RELEASE-i386-bootonly.iso
2. Enter system_powerdown in the qemu console
3. Nothing happens.

Adding --no-kvm option makes system_powerdown work:

1. qemu --no-kvm -cdrom ~/.VirtualBox/libvirt/FreeBSD-8.1-RELEASE-i386-bootonly.iso
2. system_powerdown
3. FreeBSD installer shows the shutdown dialog as expected

Tested on FreeBSD 6.4, 7.2, and 8.0 with qemu-kvm 0.12.5 and older versions.

Andrey Golovizin (ero-sennin) wrote :

The subject should be: system_powerdown is NOT working - can someone correct this please?

I have the same issue with FreeBSD 8.1-RELEASE (i386 and x86_64) on qemu-kvm 0.12.5 (Fedora 13)

system_powerdown works properly for Linux and Windows 2008 guests, but not for FreeBSD The ACPI power button event is not received by the FreeBSD guest.

I found this (unconfirmed) status report:
http://www.spinics.net/lists/kvm/msg40064.html

So it seems to be a regression...

This is fixed upstream (in seabios actually) by commit 6d5a2172f2b76900572107868ec080400c4f615d -- see http://git.linuxtogo.org/?p=kevin/seabios.git;a=commit;h=6d5a2172f2b76900572107868ec080400c4f615d . I added this patch to Debian releases of qemu-kvm, both for squeeze and experimental.

affects: qemu-kvm (Debian) → debian
Changed in debian:
importance: Unknown → Undecided
status: Unknown → New
Andrey Golovizin (ero-sennin) wrote :

The updated bios.bin works fine for me, thanks.

Samuel Bronson (naesten) on 2012-08-04
summary: - system_powerdown is working in qemu-kvm with KVM enabled for FreeBSD
+ system_powerdown NOT working in qemu-kvm with KVM enabled for FreeBSD
guests
Thomas Huth (th-huth) wrote :

Marking this now as "Fix released" according to comment #3

Changed in qemu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.