I/O errors with qemu-nbd/qcow2

Bug #583296 reported by David Weber on 2010-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

I tried to open a qcow2 file with qemu-nbd and backup the files in it. After some coping I get lot of I/O errors in dmesg and the system hangs. One time I got even a kernel panic (Of course on a productive Server ;-) )

How to reproduce:
1. Connect nbd to a qcow2 file, a virtual machine mustn't use this file:
qemu-nbd --connect=/dev/nbd0 /mnt/qcow/andromeda.qcow2
2. Read some data from /dev/nbd0p1
dd if=/dev/nbd0p1 of=/dev/null bs=1M

After a few Seconds till Minutes somethings crash's

Attached some dmesg logs

David Weber (wb-munzinger) wrote :
David Weber (wb-munzinger) wrote :

I forgot: this is on Ubuntu 10.04, Qemu 0.12.3.

Hi,

I tried this with qemu-img version 1.0, Ubuntu 12.04 host and gentoo guest, with qcow2 disk image.
This seems to work fine. Perhaps it was fixed in the new qemu-img versions.

shehbaz@BLAckArrOw:~$sudo dd if=/dev/nbd0 of=/dev/null bs=1M
8192+0 records in
8192+0 records out
8589934592 bytes (8.6 GB) copied, 185.003 s, 46.4 MB/s
shehbaz@BLAckArrOw:~$

Did you try working with some other disk image? Did this issue get resolved already? Perhaps more information will be required to debug this now.

Paolo Bonzini (bonzini) wrote :

qemu-nbd has been rewritten since 0.12.3. Closing.

Changed in qemu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments