Scrolling artifacts on some guests

Bug #397212 reported by Dinesh Subhraveti on 2009-07-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned
Fedora
Fix Released
Medium

Bug Description

Screen doesn't refresh properly when scrolling (see the attachment).

The behavior is seen on RHEL 4.8 and SLES 11, but not on RHEL 5.3. However, on RHEL5.3, scrolling is very sluggish. It seems to be a trade-off between quick movement and frequent / accurate refreshing.

Command line:

qemu-system-x86_64 -m 2048 -drive file=/scratch/images/SLES-11-GMC-x86_64.raw -net nic,vlan=0,macaddr=DE:AD:BE:EF:88:95,model=rtl8139 -net tap -vnc :40 -boot cd -monitor stdio -smp 4

Description of problem:
after for example catting a large file inside an xterm there are text artifacts remaining inside the xterm window. Scrolling up and down the xterm makes things even worse.

Not sure if it's related to window scaling, please reassign appropriately if not a virt-manager bug.

Screenshot attached

Version-Release number of selected component (if applicable):
virt-manager-0.7.0-5.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. start VM
2. open xterm inside VM
3. cat large file (/var/log/messages) and scroll to make things worse

Actual results:
text appears garbled

Expected results:
text appears normal without artifacts

Additional info:

Created attachment 345887
garbled-xterm.png

Yeah, I can reproduce this, even with vncviewer - doesn't seem reproducible outside of KVM, though

Moving to qemu

This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

bug #507626 is probably a dup of this

Dinesh Subhraveti (subhraveti) wrote :

From your command line, I suspect you're testing a copy of KVM. Is this reproducible with the upstream QEMU and if so, with what version (either 0.10.5 or specific git commit)?

Dinesh Subhraveti (subhraveti) wrote :

Yes, reproducible upstream.

commit 9af4aed6c749786edb780e5de1795377f515e8f7
Author: Andre Przywara <email address hidden>
Date: Thu Jul 2 16:45:43 2009 +0200

Mark McLoughlin (markmc) wrote :

Two Fedora 11 (qemu-0.10.x) bugs on this too:

  https://bugzilla.redhat.com/503156
  https://bugzilla.redhat.com/507626

Changed in fedora:
status: Unknown → In Progress

*** Bug 507626 has been marked as a duplicate of this bug. ***

Changed in fedora:
status: In Progress → Invalid

Glauber, do you plan to push updated builds with this patch for F-11? I don't see this patch incorporated on any of the recent koji builds..?

The patched was NACKed upstream by Gerd. He believes there is a better way to solve it. As such, I indent to wait for the real fix, or write it myself it Gerd takes too long

Gerd has posted an updated patch here:

http://lists.gnu.org/archive/html/qemu-devel/2009-07/msg02107.html

my test machine is down presently, so haven't had chance to test it yet.

Have been playing with this a bit, and unfortunately applying the patch in comment #10 against 0.10.5 requires picking up a fair amount of the recent vnc logic changes (vnc.c and vnc.h) - not sure how you'd recommend proceeding here? One option would be to pull vnc.[c,h] from the current HEAD and add the patch, I suppose.. not sure what else might break.

So, the upstream commit is:

  http://git.savannah.gnu.org/cgit/qemu.git/commit/?id=3e28c9adf4

and it depends on the fix for bug #501131 which we also want back-ported

(Note the vnc copyrect patch isn't applied to the stable-0.11 branch for F-12 yet, either)

What I'd really like to see is both of these fixes back-ported to the stable-0.10 branch and sent upstream to qemu-devel

Brad Johnson (kkhww1902) on 2009-08-13
Changed in qemu:
status: New → Confirmed
Changed in fedora:
status: Invalid → Unknown
Changed in fedora:
status: Unknown → In Progress

Will push this to updates-testing soon:

* Fri Sep 11 2009 Mark McLoughlin <email address hidden> - 2:0.10.6-5
- Fix vnc segfault on disconnect (#501131)
- Fix vnc screen corruption with e.g. xterm (#503156)
- Rebase vnc sasl patches on top of these two vnc fixes

qemu-0.10.6-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.6-5.fc11

Created attachment 360920
Windows XP guest with grabled screen

As the image attached in Comment #16 shows, this update doesn't fix the problem for me. This is using:

# rpm -qa | grep qemu
qemu-system-x86-0.10.6-5.fc11.x86_64
qemu-img-0.10.6-5.fc11.x86_64
qemu-common-0.10.6-5.fc11.x86_64

Thanks for testing Jonathan

No problem. Alas, if anything, the screen tearing has gotten worse with this version, rather than better - previously resizing the window in the guest triggered a redraw which would clean up the garbage (at least until scrolled again), but now that trick no longer works.

Why on earth was version 2:qemu-0.10.6-5.fc11.x86_64 released
with this "bugfix" that has made the graphics looks worse?

Good question in Comment #20. Surely that's a mistake Mark?

Sorry about that, guys

This 'fix' will be in 0.10.7, so I'm inclined to leave it in for the moment and try and get it fixed

If we don't get progress, I'll revert it soon

Is it worth pushing a build of the 0.10.7 rc to updates-testing?

Anything new on this bug?

It's been open for 5 months now.

It's realllllyyy annoying, it makes Windows even harder to use :-(

*** Bug 528939 has been marked as a duplicate of this bug. ***

What would the implications of pushing qemu 0.11 to FC11 be - would that work with libvirt and friends? If so, any chance of doing such a push?

We don't have any immediate plans to update qemu in Fedora 11 to 0.11. See:

  http://www.redhat.com/archives/fedora-virt/2009-April/msg00008.html

Honestly, it should be a lot easier to fix this bug than deal with the fallout from the inevitable regressions that would be caused by a re-base. It's just a question of someone finding the time to debug it.

(In reply to comment #27)
> We don't have any immediate plans to update qemu in Fedora 11 to 0.11. See:
>
> http://www.redhat.com/archives/fedora-virt/2009-April/msg00008.html
>
> Honestly, it should be a lot easier to fix this bug than deal with the fallout
> from the inevitable regressions that would be caused by a re-base. It's just a
> question of someone finding the time to debug it.

Bah ...

Is there some way to workaround this bug?

Is there another way to connect to the output other than VNC?

I've been using virt-manager.

Patrick - you could presumably run a VNC server inside your guest and connect to that, rather than the QEMU vnc client.

The problem with backporting a fix is that there's been a lot of code churn with the vnc related stuff in qemu, so to actually fix it would require some knowledge of the vnc stuff, rather than mechanical adding and removing of commits (I know, as I tried that sometime ago). The people with that knowledge are too busy pushing forward than looking back at old releases (understandably - it's more interesting).

qemu-0.10.6-9.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.6-9.fc11

Patrick and Jonathan: okay, let's try and hit this bad boy with our big stick

I'm pretty sure it's a problem with qemu's implementation of the CopyRect extension, so I've just disabled that extension in qemu-0.10.6-9.fc11 - that should fix the problem

AFAIK, CopyRect works fine in qemu-0.11.0 in Fedora 12

Could you confirm that qemu-0.10.6-9.fc11 fixes the issue? (comment here and bump the karma in bodhi if so)

Thanks!

* Fri Oct 23 2009 Mark McLoughlin <email address hidden> - 2:0.10.6-9
- Disable the vnc CopyRect encoding since it's still broken (#503156)

Mark: qemu-0.10.6-9.fc11 does indeed fix the issue for me. Thanks very much for taking the time to look at this.

(In reply to comment #32)
> Mark: qemu-0.10.6-9.fc11 does indeed fix the issue for me. Thanks very much for
> taking the time to look at this.

Me too, thanks!

I commented on the web page (showed up as anonymous), but how do I bump bodhi karma?

Changed in fedora:
status: In Progress → Fix Committed

qemu-0.10.6-9.fc11 has been pushed to the Fedora 11 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update qemu'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10754

qemu-0.10.6-9.fc11 has been pushed to the Fedora 11 stable repository. If problems still persist, please make note of it in this bug report.

Changed in fedora:
status: Fix Committed → Fix Released
Changed in qemu:
status: Confirmed → Fix Released
Changed in fedora:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.