[Feature request] Propagate interpreter to spawned processes

Bug #1918975 reported by Rado Smogura
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Wishlist
Unassigned

Bug Description

I want QEMU user static to propagate interpreter to spawned processes, for instances by adding -R recursive.

I.e. if my program is interpreted by QEMU static than everything what it launches should be interpreted by it, too.

Revision history for this message
Thomas Huth (th-huth) wrote :

The QEMU project is currently moving its bug tracking to another system.
For this we need to know which bugs are still valid and which could be
closed already. Thus we are setting the bug state to "Incomplete" now.

If the bug has already been fixed in the latest upstream version of QEMU,
then please close this ticket as "Fix released".

If it is not fixed yet and you think that this bug report here is still
valid, then you have two options:

1) If you already have an account on gitlab.com, please open a new ticket
for this problem in our new tracker here:

    https://gitlab.com/qemu-project/qemu/-/issues

and then close this ticket here on Launchpad (or let it expire auto-
matically after 60 days). Please mention the URL of this bug ticket on
Launchpad in the new ticket on GitLab.

2) If you don't have an account on gitlab.com and don't intend to get
one, but still would like to keep this ticket opened, then please switch
the state back to "New" or "Confirmed" within the next 60 days (other-
wise it will get closed as "Expired"). We will then eventually migrate
the ticket automatically to the new system (but you won't be the reporter
of the bug in the new system and thus you won't get notified on changes
anymore).

Thank you and sorry for the inconvenience.

tags: added: feature-request linux-user
Changed in qemu:
importance: Undecided → Wishlist
status: New → Incomplete
Revision history for this message
Thomas Huth (th-huth) wrote :

Also, is this a duplicate of https://bugs.launchpad.net/qemu/+bug/1912107 or do you mean something different here?

Revision history for this message
Rado Smogura (rado-smg) wrote :

Hi,

This is the same bug, child processes from quemu are not quemu. I think I know how this can be fixed, but right now I have no time to even try it.

Revision history for this message
Rado Smogura (rado-smg) wrote :

However use case is a bit different, I don't use binfmtmisc - so I will leave it to your decision, if it's same or not.

I.e. Imagine I run sh with qemu - I want any process launched from sh to be as well qemu interpreted.

Revision history for this message
Thomas Huth (th-huth) wrote :

I think one ticket should be enough to track this problem, so let's continue the discussion here:

 https://gitlab.com/qemu-project/qemu/-/issues/306

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.