[git] Cannot build qemu: FAILED: target/hexagon/semantics_generated.pyinc

Bug #1916394 reported by Frederic Bezies
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Invalid
Undecided
briancain

Bug Description

Hello.

I'm using Archlinux and I maintain qemu-git AUR package.

I tried to build Qemu at commit 4115aec9af2a3de5fa89a0b1daa12debcd7741ff but it stops with this error message:

Found ninja-1.10.2 at /usr/bin/ninja
[632/9068] Generating semantics_generated.pyinc with a custom command
FAILED: target/hexagon/semantics_generated.pyinc
@INPUT@ target/hexagon/semantics_generated.pyinc
/bin/sh: line 1: @INPUT@: command not found
[637/9068] Compiling C object fsdev/vi...proxy-helper.p/virtfs-proxy-helper.c.o
ninja: build stopped: subcommand failed.

ninja version: 1.10.2
meson version: 0.57.1

Downgrading meson doesn't change anything.

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
Revision history for this message
Frederic Bezies (fredb74) wrote :

Last commit which build is going to its end: https://git.qemu.org/?p=qemu.git;a=commit;h=08895cda3a57fe2d72ef621800606ddc2f5eb612

Will try to see later with hexagon patches to see which one is breaking the build process.

Here are the configure options I'm using:

--prefix=/usr
--sysconfdir=/etc
--localstatedir=/var
--libexecdir=/usr/lib/qemu
--extra-ldflags="$LDFLAGS"
--smbd=/usr/bin/smbd
--enable-modules
--enable-sdl
--disable-werror
--enable-vhost-user
--enable-slirp=system
--enable-xfsctl
--audio-drv-list="pa alsa sdl"

LDFLAGS: -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now

Revision history for this message
Frederic Bezies (fredb74) wrote :

Here is what I found to narrow the commit which breaks the build process.

Last working commit: 2184bca7b17559107032ba4fd8fc6f65345276ed -> "qapi: Replace List[str] with Sequence[str] for ifcond"

First broken commit: 3e7a84eeccc3b3a9b43c6dfb52bd98ea5acebf0a -> "Hexagon build infrastructure"

Revision history for this message
briancain (brian-cain) wrote :

I can't seem to reproduce this locally, I will try to see if I can get my configuration to match yours more closely.

Does the attached patch mitigate the build issue? 0001-target-hexagon-fix-meson-build-failure.patch

Revision history for this message
Frederic Bezies (fredb74) wrote :

Sorry for the late reply. Tried patch... Here is the output:

Option b_staticpic is: false [default: false]
Found ninja-1.10.2 at /usr/bin/ninja
[658/9072] Generating iset.py with a custom command
FAILED: target/hexagon/iset.py
@INPUT@ target/hexagon/iset.py
/bin/sh: line 1: @INPUT@: command not found
[663/9072] Compiling C object tests/qtest/libqos/libqos.fa.p/.._libqtest.c.o
ninja: build stopped: subcommand failed.

Still busted. Nothing changed.

briancain (brian-cain)
Changed in qemu:
assignee: nobody → briancain (brian-cain)
Revision history for this message
briancain (brian-cain) wrote :

Still having trouble reproducing the issue.

I don't have an arch system so I used Docker. Would you be willing to check whether the Dockerfile represents a close enough match to your build process?

Also, if you can think of anything particularly unique about your configuration, maybe I can try to come closer to reproducing this with some of those critical factors.

Revision history for this message
briancain (brian-cain) wrote :

docker_arch_qemu_build.log.xz shows the output from the docker build via arch linux

Revision history for this message
Frederic Bezies (fredb74) wrote :

I looked at it, and there seems to be no difference. Looks like my installation is rotten.

Let's close this bug as invalid.

Revision history for this message
Frederic Bezies (fredb74) wrote :

I tried something else, and build process went right: building qemu in a clean-chroot: https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot

 Well, something is broken on my real installation, or it could be a bug in a package as I'm using testing. Anyway, this bug can be closed as I can build Qemu successfully now.

briancain (brian-cain)
Changed in qemu:
status: New → Invalid
Revision history for this message
briancain (brian-cain) wrote :

Looks like there's a patch proposed that sounds as if it would mitigate this symptom:

https://mail.gnu.org/archive/html/qemu-devel/2021-03/msg02879.html

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers