hmp command `hostfwd_remove` does not work on running vm

Bug #1911797 reported by Ven Karri
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

On a running VM, I ran the following two hmp commands:

"hostfwd_add tcp::43210-:43210" --> WORKS
'hostfwd_remove tcp::43210-:43210" --> DOES NOT WORK. returns 'invalid format'

QEMU version 5.1

Revision history for this message
Alexander Bulekov (a1xndr) wrote :

Looks like intended behavior:

(qemu) help hostfwd_add
hostfwd_add [netdev_id] [tcp|udp]:[hostaddr]:hostport-[guestaddr]:guestport -- redirect TCP or UDP connections from host to guest (requires -net user)
(qemu) help hostfwd_remove
hostfwd_remove [netdev_id] [tcp|udp]:[hostaddr]:hostport -- remove host-to-guest TCP or UDP redirection

Revision history for this message
Ven Karri (imperialguy) wrote :

Not sure I understand. The intended behavior is to remove the ports. It doesn't do that. And it returns 'invalid format'.

Revision history for this message
Ven Karri (imperialguy) wrote :

(qemu) hostfwd_add tcp::43210-:43210
(qemu) hostfwd_remove tcp::43210-:43210
invalid format

Revision history for this message
Ven Karri (imperialguy) wrote :

My bad. The correct command is this:
(qemu) hostfwd_remove tcp::43210
This bug can be closed.

Changed in qemu:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers