Strange keyboard behaviour in Vim editor

Bug #1897568 reported by Albert Wik
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

I'm running MS-DOS 7.10 in a QEMU virtual machine, and there is a problem with the keyboard in the Vim editor. The arrow keys jump over a line, as if you had typed the key twice. PgUp and PgDn are likewise affected. Other applications are not affected, unless you shell out from Vim.

The QEMU version is 5.0.0, and I'm using the "-k sv" option, but I've tried without it and it doesn't make a difference.

I don't get this keyboard behaviour in the exact same VM under VMware Player or Bochs.

-Albert.

Revision history for this message
Philippe Mathieu-Daudé (philmd) wrote :

Possible fix:
https://<email address hidden>/msg804823.html

Changed in qemu:
status: New → Confirmed
Thomas Huth (th-huth)
Changed in qemu:
status: Confirmed → In Progress
Revision history for this message
Thomas Huth (th-huth) wrote :

The patch mentioned by Philippe has now been merged to the QEMU master branch (commit d1e45668d2128b064). Albert, could you maybe check the current git version to see whether this problem has been fixed now (using "-global i8042.kbd-throttle=on" to enable this new feature)?

Changed in qemu:
status: In Progress → Fix Committed
Revision history for this message
Albert Wik (awik) wrote : Re: [Bug 1897568] Re: Strange keyboard behaviour in Vim editor

Hi,

thanks for letting me know.

I do plan to test this and report back, but that may take some time, as I
would first have to compile and install a new version of QEMU.

-aw

On Thu, 27 May 2021 at 05:10, Thomas Huth <email address hidden>
wrote:

> The patch mentioned by Philippe has now been merged to the QEMU master
> branch (commit d1e45668d2128b064). Albert, could you maybe check the
> current git version to see whether this problem has been fixed now
> (using "-global i8042.kbd-throttle=on" to enable this new feature)?
>
> ** Changed in: qemu
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1897568
>
> Title:
> Strange keyboard behaviour in Vim editor
>
> Status in QEMU:
> Fix Committed
>
> Bug description:
>
> I'm running MS-DOS 7.10 in a QEMU virtual machine, and there is a
> problem with the keyboard in the Vim editor. The arrow keys jump over a
> line, as if you had typed the key twice. PgUp and PgDn are likewise
> affected. Other applications are not affected, unless you shell out from
> Vim.
>
> The QEMU version is 5.0.0, and I'm using the "-k sv" option, but I've
> tried without it and it doesn't make a difference.
>
> I don't get this keyboard behaviour in the exact same VM under VMware
> Player or Bochs.
>
> -Albert.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/qemu/+bug/1897568/+subscriptions
>

Revision history for this message
felix (felix.von.s) wrote :

Can someone explain why the patch keeps the incorrect behaviour as the default? It’s silly.

Revision history for this message
Thomas Huth (th-huth) wrote :

Felix, if you want to discuss the default behaviour, please get in touch with the author of the patch, since he might not read this bug tracker here.
Anyway, the patch has been released with QEMU 6.1, so I'm closing this ticket here now.

Changed in qemu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers