Windows XP takes much longer to boot in TCG mode since 5.0

Bug #1883593 reported by Randy Rhoads
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

Since upgrading from 4.2 to 5.0, a Windows XP VM takes much longer to boot.

It hangs about three minutes on "welcome" screen with the blue background, while previously the total boot time was less than a minute.

The issue only happens in TCG mode (not with KVM) and also happens with the current master which includes the uring patches (7d3660e7).

I can reproduce this issue with a clean XP install with no flags other than `-m 2G`. After booting, the performance seems to be normal.

Tags: tcg Edit Tag help
Revision history for this message
Alex Bennée (ajbennee) wrote :

Are you able to bisect between 4.2 and 5.0 and identify what introduces the slow down?

tags: added: tcg
Revision history for this message
Randy Rhoads (randy3) wrote :

Bisecting showed that this is the bad commit:

    b55f54bc965607c45b5010a107a792ba333ba654 exec: flush CPU TB cache in breakpoint_invalidate

And I can indeed confirm that this commit is much slower than the previous one, e18e5501d8ac692d32657a3e1ef545b14e72b730.

Randy Rhoads (randy3)
information type: Public → Public Security
information type: Public Security → Public
Revision history for this message
Thomas Huth (th-huth) wrote :

The QEMU project is currently moving its bug tracking to another system.
For this we need to know which bugs are still valid and which could be
closed already. Thus we are setting older bugs to "Incomplete" now.

If the bug has already been fixed in the latest upstream version of QEMU,
then please close this ticket as "Fix released".

If it is not fixed yet and you think that this bug report here is still
valid, then you have two options:

1) If you already have an account on gitlab.com, please open a new ticket
for this problem in our new tracker here:

    https://gitlab.com/qemu-project/qemu/-/issues

and then close this ticket here on Launchpad (or let it expire auto-
matically after 60 days). Please mention the URL of this bug ticket on
Launchpad in the new ticket on GitLab.

2) If you don't have an account on gitlab.com and don't intend to get
one, but still would like to keep this ticket opened, then please switch
the state back to "New" within the next 60 days (otherwise it will get
closed as "Expired"). We will then eventually migrate the ticket auto-
matically to the new system.

Thank you and sorry for the inconvenience.

Changed in qemu:
status: New → Incomplete
Peter Maydell (pmaydell)
Changed in qemu:
status: Incomplete → New
Revision history for this message
Thomas Huth (th-huth) wrote : Moved bug report

This is an automated cleanup. This bug report has been moved to QEMU's
new bug tracker on gitlab.com and thus gets marked as 'expired' now.
Please continue with the discussion here:

 https://gitlab.com/qemu-project/qemu/-/issues/404

Changed in qemu:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.