MacOS host qemu-system-x86_64 -cpu host not working

Bug #1872644 reported by JS
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

MacOS: 10.15.4
uname -a: Linux door 4.15.0-96-generic #97-Ubuntu SMP Wed Apr 1 03:25:46 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I am using qemu on mac host, with ubuntu client.

I used to have "-cpu host" in my qemu command as follow:-

qemu-system-x86_64 \
-no-user-config \
-nodefaults \
-name u64d01 \
-show-cursor \
-M q35,accel=hvf,usb=off,vmport=off \
-cpu host \
-m 8192M \
-smp 4 \
-rtc base=utc,clock=host \
-device virtio-blk-pci,drive=ssd1 \
-drive id=ssd1,file=/Users/js/code/vm/qemu/u64d01.qcow2,if=none,format=qcow2 \
-device virtio-net-pci,netdev=nic1,mac=52:54:98:76:54:33 \
-netdev user,id=nic1,ipv4=on,ipv6=on,hostname=u64d01,hostfwd=tcp::2222-:22 \
-device virtio-tablet-pci \
-device virtio-vga \
-device ich9-intel-hda,id=snd,msi=on \
-device hda-output,id=snd-codec0,bus=snd.0,cad=0,audiodev=snd0 \
-audiodev coreaudio,id=snd0

Base on log of one of the vm, it was definitely working on 2020-01-17(base on journal inside vm), with qemu 4.2.0, which I installed with brew.

The only way to make it work is to remove "-cpu host".

Already tried with 4.1.1, 4.2 and 5.0rc2. Same result.

To reproduce, try above with a Ubuntu 18.04 installation cd. Client will crash during kernel loading.

Revision history for this message
JS (js1943) wrote :
tags: added: hvf
Revision history for this message
Sitsofe Wheeler (sitsofe) wrote :

I found that things were unstable unless the following were also added
-cpu Nehalem,-rdtscp
(the CPU can be higher than Nehalem but obviously your host CPU actually has to be equal or greater too)

-rdtscp is a known issue that has since been workedaround (see bug #1894836 ).

Revision history for this message
Thomas Huth (th-huth) wrote :

The QEMU project is currently moving its bug tracking to another system.
For this we need to know which bugs are still valid and which could be
closed already. Thus we are setting older bugs to "Incomplete" now.

If you still think this bug report here is valid, then please switch
the state back to "New" within the next 60 days, otherwise this report
will be marked as "Expired". Or please mark it as "Fix Released" if
the problem has been solved with a newer version of QEMU already.

Thank you and sorry for the inconvenience.

tags: added: macos
Changed in qemu:
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for QEMU because there has been no activity for 60 days.]

Changed in qemu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers