Snapshots freeze guest Sabrelite IMX.6 board

Bug #1839807 reported by Al Sn
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

Hello,

I'm trying to take and restore a snapshot with the whole system state of the Sabrelite IMX.6 board running on QEMU with commands savevm/loadvm.
It seems that I am able to take a snapshot but loading the snapshot fails.

For comparison I checked out snapshots on 32bit ARM Virt with Debian as well as on the Versatilepb board with a bare metal application and it works fine.
The problem occurs only with that one particular board.

My environment is:
Ubuntu 18.04
QEMU 3.0.1 (I see the same issue in QEMU 4.0.0 as well)
The kernel and device tree used for the board was 5.1.14 version from kernel.org

The file system was build from imx_v6_v7_defconfig config in buildroot as and sd card image.

Problem:

Loading snapshot stops the whole machine and it's impossible to resume it.

Steps to reproduce problem:

1. I converted the sdcard.img built from the buildroot to qcow2 using command qemu-img convert -f raw -O qcow2 sdcard.img sdcard.qcow2, since the raw doesn't support snapshots.

2. I start QEMU with a command
./arm-softmmu/qemu-system-arm -m 512 -M sabrelite -kernel zImage -append "rootfstype=ext4 root=/dev/mmcblk2p2 rw rootwait" -rtc base=localtime,clock=vm -dtb imx6dl-sabresd.dtb -drive file=sdcard.qcow2,index=2,format=qcow2,id=mycard -device sd-card,drive=mycard -nographic -net nic -net user

3. I run a simple program which print characters to the console in the background and add some files in user directory, to differ from original image.

4. I switch to QEMU monitor, and type “savevm <name>”.
When I type “info snapshots”, the snapshot is listed.
So I assume it was saved correctly.

5. Then I switch back to Linux console from monitor, remove the added files and stop the background printing process.

6. I switch back to monitor and I'm trying now to load the snapshot by “loadvm <name>” command.

That’s where the problem occurs. QEMU stops and I can't switch back from monitor to Linux.
Typing “cont” doesn’t help.
It seems like the simulation has freezed. CPU usage on my Laptop machine equals 100% until I exit QEMU.

What’s interesting when I exit the QEMU and then start it again the Linux boots and after it reaches the command prompt I can see the files which were removed after saving the snapshot.

It looks like loading the snapshots works for restoring disk space but it fails for restoring the running processes.

Due to the answer on QEMU mailing list (https://lists.nongnu.org/archive/html/qemu-discuss/2019-08/msg00016.html) it is QEMUs bug.

Revision history for this message
Peter Maydell (pmaydell) wrote :

The underlying cause of this is that we're not migrating the Secure banked cp15 register contents. So boards which don't enable TrustZone or where the guest runs in the NonSecure state (like the virt board, etc) can save/restore fine, but since the imx6 happens to run the guest in the Secure state it gets hit by the bug and its MMU setup etc is completely broken on restore.

This is a bug I knew about (I mentioned it in LP:1739378 comment #5), but I've forgotten the detail of why it happens and don't seem to have written it down, so I'm going to have to think it through again...

Changed in qemu:
status: New → Confirmed
tags: added: arm
Revision history for this message
Al Sn (alsn) wrote :

Hello again,

I have tried to disable TrustZone using argument mentioned in comment #5 by changing -M sabrelite to -M sabrelite,secure=off, but I get error "qemu-system-arm: Property '.secure' not found". It works with virt though. Is there any other way to disable it?

Thank you,
...

Revision history for this message
Peter Maydell (pmaydell) wrote :

That property doesn't exist for the sabrelite board, it's only on some of the others like vexpress or virt.

Revision history for this message
Thomas Huth (th-huth) wrote :

The QEMU project is currently moving its bug tracking to another system.
For this we need to know which bugs are still valid and which could be
closed already. Thus we are setting the bug state to "Incomplete" now.

If the bug has already been fixed in the latest upstream version of QEMU,
then please close this ticket as "Fix released".

If it is not fixed yet and you think that this bug report here is still
valid, then you have two options:

1) If you already have an account on gitlab.com, please open a new ticket
for this problem in our new tracker here:

    https://gitlab.com/qemu-project/qemu/-/issues

and then close this ticket here on Launchpad (or let it expire auto-
matically after 60 days). Please mention the URL of this bug ticket on
Launchpad in the new ticket on GitLab.

2) If you don't have an account on gitlab.com and don't intend to get
one, but still would like to keep this ticket opened, then please switch
the state back to "New" or "Confirmed" within the next 60 days (other-
wise it will get closed as "Expired"). We will then eventually migrate
the ticket automatically to the new system (but you won't be the reporter
of the bug in the new system and thus you won't get notified on changes
anymore).

Thank you and sorry for the inconvenience.

Changed in qemu:
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for QEMU because there has been no activity for 60 days.]

Changed in qemu:
status: Incomplete → Expired
Revision history for this message
Peter Maydell (pmaydell) wrote :

Save/restore with TrustZone enabled is stil broken.

Changed in qemu:
status: Expired → New
Revision history for this message
Thomas Huth (th-huth) wrote : Moved bug report

This is an automated cleanup. This bug report has been moved to QEMU's
new bug tracker on gitlab.com and thus gets marked as 'expired' now.
Please continue with the discussion here:

 https://gitlab.com/qemu-project/qemu/-/issues/467

Changed in qemu:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.