RFE: populate "OEM Strings" (type 11) SMBIOS table strings from regular files

Bug #1826200 reported by Laszlo Ersek (Red Hat) on 2019-04-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Daniel Berrange

Bug Description

The feature added in

  https://git.qemu.org/?p=qemu.git;a=commitdiff;h=2d6dcbf93fb01b4a7f45a93d276d4d74b16392dd

and exposed by libvirt as

  https://libvirt.org/formatdomain.html#elementsSysinfo

allows the user to specify up to 255 strings in the unofmatted area of the Type 11 SMBIOS table, where each string may be of arbitrary length. This feature is useful for exposing arbitrary text to arbitrary guest components (in particular when strings are prefixed with "application identifiers").

Right now, strings can only be specified on the QEMU command line, which limits the amount of data that can be passed. Please enable users to pass data from regular files too.

For example:

  $QEMU -smbios type=11,value=Hello,txtfile=file1.txt,txtfile=file2.txt

where "file1.txt" and "file2.txt" could be text files containing ASCII application prefixes, followed by base64-encoded binary data.

Changed in qemu:
status: New → Confirmed
assignee: nobody → Daniel Berrange (berrange)
Laszlo Ersek (Red Hat) (lersek) wrote :

We'll probably never have resources for this -- nice to have feature, but has not become critical in ~1.5 years. LP doesn't allow me to close the ticket as "Won't Fix", so I'll have to go with "Invalid". (The report is not invalid at all, but the ticket status should *somehow* reflect that we have no resources for working on this.)

Changed in qemu:
status: Confirmed → Invalid
Daniel Berrange (berrange) wrote :

Surprise...

https://lists.gnu.org/archive/html/qemu-devel/2020-09/msg03023.html

Discovering the firmware limits was tedious. SeaBIOS limits SMBIOS to 64KB total size due to support for SMBIOS 2.1 spec only, while EDK2 fails a little over 128 KB total size despite supporting SMBIOS 3.0 which should not be limited IIUC

Changed in qemu:
status: Invalid → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.