claims temp file is used by another process

Bug #1774853 reported by tsiros
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

QEMU emulator version 2.12.50 (v2.12.0-12378-g99a34dc4d2-dirty)

"c:\Program Files\qemu\qemu-system-x86_64.exe" -net none -parallel none -bios OVMF.fd -L . -hda fat:rw:image
vvfat image chs 1024,16,63
c:\Program Files\qemu\qemu-system-x86_64.exe: -hda fat:rw:image: Could not open 'C:\Users\tsiros\AppData\Local\Temp\qem5B92.tmp': The process cannot access the file because it is being used by another process.

Revision history for this message
tsiros (tsiros) wrote :

someone please delete this

Changed in qemu:
status: New → Invalid
Revision history for this message
Alexandro Sanchez Bach (alexaltea) wrote :

@tsiros, can you explain why this isn't an issue for you anymore? This is precisely what happens to me, specifically when I create drives as `file=fat:rw:path/to/dir`. When I type `fat:path/to/dir`, everything works fine, though I get some warnings. Was this fixed in newer versions or did you simply realized some issue on your side? Thanks.

Revision history for this message
Mason Back (masonleeback) wrote :

Hi there! Our fork of QEMU still happens to have this issue. Did you happen to find a solution?

$ ../orbital-qemu/ps4-softmmu/qemu-system-ps4 -bios ./ubios.bin -kernel ./boot.img -drive file=hdd.qcow2 -drive file=fat:rw:sflash/,media=disk -monitor stdio -smp 8 -display orbital
vvfat sflash/ chs 1024,16,63
C:\tools\msys64\home\Alex\orbital\orbital-qemu\ps4-softmmu\qemu-system-ps4.exe: -drive file=fat:rw:sflash/,media=disk: Could not open 'C:\tools\msys64\tmp\qem1DF0.tmp': The process cannot access the file because it is being used by another process.

Changed in qemu:
status: Invalid → New
Revision history for this message
tsiros (tsiros) wrote : Re: [Bug 1774853] Re: claims temp file is used by another process

I can't remember at all!

i am sorry i know how frustrating this is

i don't remember even if i fixed it or if i gave up

On Thu, Jun 13, 2019, 03:20 Alexandro Sanchez Bach <
<email address hidden>> wrote:

> @tsiros, can you explain why this isn't an issue for you anymore? This
> is precisely what happens to me, specifically when I create drives as
> `file=fat:rw:path/to/dir`. When I type `fat:path/to/dir`, everything
> works fine, though I get some warnings. Was this fixed in newer versions
> or did you simply realized some issue on your side? Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1774853
>
> Title:
> claims temp file is used by another process
>
> Status in QEMU:
> New
>
> Bug description:
> QEMU emulator version 2.12.50 (v2.12.0-12378-g99a34dc4d2-dirty)
>
> "c:\Program Files\qemu\qemu-system-x86_64.exe" -net none -parallel none
> -bios OVMF.fd -L . -hda fat:rw:image
> vvfat image chs 1024,16,63
> c:\Program Files\qemu\qemu-system-x86_64.exe: -hda fat:rw:image: Could
> not open 'C:\Users\tsiros\AppData\Local\Temp\qem5B92.tmp': The process
> cannot access the file because it is being used by another process.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/qemu/+bug/1774853/+subscriptions
>

Revision history for this message
Thomas Huth (th-huth) wrote :

Is this still reproducible with the latest version of QEMU, or could this ticket be closed nowadays?

Changed in qemu:
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for QEMU because there has been no activity for 60 days.]

Changed in qemu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers