getifaddrs: Address family not supported by protocol

Bug #1581695 reported by chrisber on 2016-05-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

Calling ip addr fails with the following error message:
Cannot open netlink socket: Address family not supported by protocol

My use case is running a docker raspberry pi arm container on Ubuntu 14.04 x64 with qemu-static.

My steps to reproduce are the following:

# docker pull philipz/rpi-raspbian:latest
# docker run -it --rm -v /usr/bin/qemu-arm-static:/usr/bin/qemu-arm-static philipz/rpi-raspbian bash
root@3b4ddc174279:/# ip addr
Cannot open netlink socket: Address family not supported by protocol

A fix or an workaround would be awesome.

note: we are also working with a embedded arm distro which has no package manager available, would be nice if the workaround would not depend on apt-get

Peter Maydell (pmaydell) wrote :

We got netlink sockets working for linux-user over the course of 2016, and "ip addr" now works for me with a 32-bit arm chroot. This should be fixed in QEMU 2.10.

Changed in qemu:
status: New → Fix Released
tags: added: linux-user
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers