Qemu 2.5 dont start with sdl,gl=on or gtk,gl=on

Bug #1555076 reported by luigiburdo on 2016-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

with this config line
 qemu-system-i386 -m 2047 -hda /dev/sda3 -display sdl,gl=on -sdl -vga virtio -cdrom xenial-desktop-i386.iso

i have this exit

ERROR:ui/console-gl.c:95:surface_gl_create_texture: code should not be reached

same is i use this:

qemu-system-i386 -m 2047 -hda /dev/sda3 -display gtk,gl=on -sdl -vga virtio -cdrom xenial-desktop-i386.iso
ERROR:ui/console-gl.c:95:surface_gl_create_texture: code should not be reached

My Os i Debian Jessie on P5020 PPC64 4GB ram GPU RadeonHD .
Configure gave me gl ok, sdl ok , Virtio and Virgl OK .

My Mesa are the 11.3 dev ... the same issue was found on oldest and stable release of mesa .

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD TURKS (DRM 2.43.0)
OpenGL version string: 2.1 Mesa 11.3.0-devel (git-3146014)
OpenGL shading language version string: 1.30

OpenGL ES profile version string: OpenGL ES 2.0 Mesa 11.3.0-devel (git-3146014)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16

Thanks
Luigi

Thomas Huth (th-huth) wrote :

Is this the same issue as the bug reported here:
https://bugs.launchpad.net/qemu/+bug/1581796
?

luigiburdo (intermediadc) wrote :

Sorry T,
i forget had been reported and duplicate the bug report.
can merge or close this one.

i will check with your suggestion and report.

Thomas Huth (th-huth) wrote :

Fix has been pulled into the QEMU git repository:
http://git.qemu.org/?p=qemu.git;a=commitdiff;h=2c2311c5451f4555e850772

Changed in qemu:
status: New → Fix Committed
Thomas Huth (th-huth) wrote :

Released with version 2.7

Changed in qemu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers