support vhost user without specifying vhostforce

Bug #1546445 reported by Liang Chen on 2016-02-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Liang Chen
Ubuntu Cloud Archive
Undecided
Liang Chen
Kilo
Undecided
Liang Chen
qemu (Ubuntu)
Medium
Unassigned
Wily
Medium
Unassigned

Bug Description

[Impact]

 * vhost-user falls back to virtio-net which causes performance lose without specifying the vhostforce option. But it should be the default behavior for vhost-user, since guests using PMD doesn't support msi-x.

[Test Case]

  create a vhost-user virtio backend without specifying the vhostforce option, i.e. -netdev type=vhost-user,id=mynet1,chardev=<char_dev_for_the_controll_channel>
  start the VM
  vhost-user is not enabled

[Regression Potential]

 * none

vhost user nic doesn't support non msi guests(like pxe stage) by default.
Vhost user nic can't fall back to qemu like normal vhost net nic does. So we should
enable it for non msi guests.

The problem has been fix in qemu upstream - http://git.qemu.org/?p=qemu.git;a=commitdiff;h=24f938a682d934b133863eb421aac33592f7a09e. And the patch needs to be backported to 1:2.2+dfsg-5expubuntu9.8 .

Liang Chen (cbjchen) on 2016-02-17
Changed in qemu:
assignee: nobody → Liang Chen (cbjchen)
Liang Chen (cbjchen) wrote :
Changed in qemu:
status: New → In Progress
tags: added: patch

The attachment "debian patch for qemu 1:2.2+dfsg" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

Liang Chen (cbjchen) on 2016-02-23
Changed in qemu (Ubuntu Wily):
status: New → Fix Released
Louis Bouchard (louis) on 2016-02-23
Changed in qemu (Ubuntu Vivid):
status: New → Won't Fix
no longer affects: qemu (Ubuntu Trusty)
Changed in qemu (Ubuntu):
importance: Undecided → Medium
Changed in qemu (Ubuntu Vivid):
importance: Undecided → Medium
Changed in qemu (Ubuntu Wily):
importance: Undecided → Medium
Changed in qemu (Ubuntu):
status: New → Fix Released
Changed in qemu:
status: In Progress → Fix Released
Liang Chen (cbjchen) on 2016-03-15
tags: added: sts sts-sru
Liang Chen (cbjchen) on 2016-03-15
Changed in cloud-archive:
assignee: nobody → Liang Chen (cbjchen)
status: New → In Progress
no longer affects: cloud-archive
Changed in qemu (Ubuntu Vivid):
status: Won't Fix → In Progress
assignee: nobody → Liang Chen (cbjchen)
Changed in qemu (Ubuntu Vivid):
status: In Progress → Invalid
assignee: Liang Chen (cbjchen) → nobody
no longer affects: qemu (Ubuntu Vivid)
James Page (james-page) on 2016-03-20
tags: added: verification-needed

Hello Liang, or anyone else affected,

Accepted qemu into kilo-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:kilo-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-kilo-needed to verification-kilo-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-kilo-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-kilo-needed
Changed in cloud-archive:
status: Fix Committed → Invalid
status: Invalid → Fix Released
tags: removed: verification-needed
Liang Chen (cbjchen) wrote :

Tested with 1:2.2+dfsg-5expubuntu9.7~cloud2, and the fix works for me.

tags: added: verification-kilo-done
removed: verification-kilo-needed
Ryan Beisner (1chb1n) wrote :

FYI, following additional regression tests, today we promoted qemu 2.2+dfsg-5expubuntu9.7~cloud2 from kilo-proposed to kilo-updates in the Ubuntu Cloud Archive.

Louis Bouchard (louis) on 2016-11-09
tags: removed: sts-sru
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers