qemu-img will fail to convert images in 2.3.0

Bug #1452062 reported by David Hill
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

Hello guys,

    There seems to be a bug in qemu-img with 2.3.0 that wasn't there in 2.2.1 .... qemu convert will always fail converting. See the output below:

Started by upstream project "Create windows image" build number 73
originally caused by:
 Started by user anonymous
Building remotely on builder (builder lab) in workspace /var/lib/jenkins/remote/workspace/Prepare windows Image
[Prepare WS2008R2 Image] $ /bin/sh -xe /tmp/hudson4138890034689910617.sh
+ sudo bash -x /var/images/prepare_windows.sh WS2008R2
+ set +x

Preparing: windows
Virtio CD: virtio-win-0.1.96.iso

Sparsifying...
qemu-img: error while compressing sector 11131648: Input/output error
virt-sparsify: error: external command failed: qemu-img convert -f
qcow2 -O 'qcow2' -c -o 'compat=0.10' '/tmp/sparsifyb459a0.qcow2'
'/var/images/generated/WS2008R2.qcow2'

virt-sparsify: If reporting bugs, run virt-sparsify with debugging
enabled (-v) and include the complete output.
Build step 'Execute shell' marked build as failure
Warning: you have no plugins providing access control for builds, so falling back to legacy behavior of permitting any downstream builds to be triggered
Finished: FAILURE

Thanks,
Dave

Revision history for this message
Michael Tokarev (mjt+launchpad-tls) wrote :

I can't reproduce this. qemu-img convert works just fine here.

qemu-img convert -f qcow2 -O qcow2 -c -o compat=0.10 x.img y.img

(from a random winXP guest image).

Changed in qemu:
status: New → Incomplete
Revision history for this message
Kevin Wolf (kwolf-redhat) wrote :

The only possibly relevant change I can see in 2.3 is that the qcow2 driver added an additional error check to a truncate operation. Can you please run qemu-img under strace -f and either provide the output as an attachment or paste the relevant failing call(s) if you can recognise them?

Revision history for this message
David Hill (david-hill-ubisoft) wrote :

I rolled back QEMU to 2.2.1 and it succeeded converting the image ... I'll try to see if I can re-upgrade QEMU without breaking again the CI we have here.

Revision history for this message
Kevin Wolf (kwolf-redhat) wrote :

This problem is fixed with commit 3e5feb62 ("qcow2: Handle EAGAIN returned from update_refcount"), which will be included in qemu 2.4.0.

Changed in qemu:
status: Incomplete → Fix Committed
Thomas Huth (th-huth)
Changed in qemu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers