libstdc++-6.dll is missing from your computer

Bug #1312561 reported by Rupert Russell on 2014-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Stefan Weil

Bug Description

qemu-w64-setup-20140418.exe

Windows 7 64 bit PC.

qemu-system-armw -kernel kernel-qemu -cpu arm1176 -m 256 -M versatilepb -no-reboot -serial stdio -append "root=/dev/sda2 panic=1 rootfstype=ext4 rw" -hda c:\11\rasimg\test.vhd

qemu-system-armw.exe - System Error
The program can't start because libstdc++-6.dll is missing from your computer.

Try reinstalling the program to fix this problem.

I tried reinstalling, but no change.

Newton Kitonga (nknganda) wrote :

Also getting same error when running the following command on Windows 7 64 bit.

qemu-system-arm -cpu?

I also reinstalled qemu without any luck.

Peter Maydell (pmaydell) wrote :

That DLL is the mingw C++ runtime library. We should probably make our Windows executables build with a static libstdc++.

Rupert Russell (rupert-russell) wrote :

Ok, so we need to wait for a recompiled version I guess.
I did after your post get the dll from the mingw site, and that error went away, but then replaced by application failed with (0x000007b) error.
How much of the mingw package would we need to install to fix the problem if a recompiled version is some time away please?

Paolo Bonzini (bonzini) wrote :

I think dynamic is fine, after all how is libstdc++ different from glib? Both of them need to be deployed together with the executable on Windows, because they aren't a common prerequisite.

Peter Maydell (pmaydell) wrote :

Ah, we're dynamically linking with glib too? In that case, yes, whatever mechanism we're currently using to distribute the glib DLL we should use for the libstdc++ too.

Rupert Russell (rupert-russell) wrote :

So the answer to my basic question, how to make this work is Download the mingw windows installer from here.
http://cznic.dl.sourceforge.net/project/mingwbuilds/mingw-builds-install/mingw-builds-install.exe

Install for W 64 posix or win32 and VERSION 4.6.3 (later one doesn't work with qemu-w64-setup-20140418.exe.
Add to the environment path (Something like
C:\Program Files\mingw-builds\x64-4.6.3-posix-sjlj-rev2\mingw\bin or
C:\Program Files\mingw-builds\x64-4.6.3-win32-sjlj-rev2\mingw\bin both seem to work.

JR Andreassen (janrune) wrote :

Hi...
 This is still a problem with the latest build(qemu-wXX-setup-20150510.exe).

I've tried with several different versions from the MinGW, neither work
So, which is the correct NinGW version ?
  Thanks
   JR

m4mmon (m4mmon) wrote :

Hello,

Same problem here with qemu-w64-setup-20150510.exe.
As suggested above I tried to install mingw 4.6.3 posix and set path like:
set PATH=C:\Program Files\mingw-builds\x64-4.6.3-posix-sjlj-rev2\;C:\Program Files\mingw-builds\x64-4.6.3-posix-sjlj-rev2\bin;%PATH%

I do not have the libstdc++-6.dll missing error message anymore, but now I have a entry point "__gxx_personality_seh0" missing from libstdc++-6.dll error message, so this is not the appropriate runtime.

m4mmon (m4mmon) wrote :

Forgot to tell I am running Windows 7 x64, and trying to launch qemu-system-arm.

Stefan Weil (ubuntu-weilnetz) wrote :

This is not a QEMU bug, but a problem of some installers from http://qemu.weilnetz.de/.
http://qemu.weilnetz.de/w64/qemu-w64-setup-20150424.exe should work.

Get the missing dll from http://qemu.weilnetz.de/w64/dll/.

Reporting problems to the right address (here the owner of weilnetz.de) would help to
get a faster response in the future.

Regards
Stefan

Changed in qemu:
status: New → Invalid
assignee: nobody → Stefan Weil (ubuntu-weilnetz)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers