qtest failures leave orphaned qemu processes hanging around

Bug #1133769 reported by Cole Robinson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

If a qtest test case fails, it leaves orphaned qemu processes hanging around. On Fedora 18 with qemu.git as of today ( Feb 26 2013), the patch just forces a test failure

ps axwww | grep qemu | grep -v grep
$ make check-qtest-x86_64
  CC tests/rtc-test.o
  LINK tests/rtc-test
GTESTER check-qtest-x86_64

$ ps axwww | grep qemu | grep -v grep
$ patch -p1 < force-test-failure.patch
patching file tests/rtc-test.c

$ make check-qtest-x86_64
  CC tests/rtc-test.o
  LINK tests/rtc-test
GTESTER check-qtest-x86_64
**
ERROR:tests/rtc-test.c:256:bcd_check_time: assertion failed: (0)
GTester: last random seed: R02Sf2521dda395a2713128e0cbf86651a21
make: *** [check-qtest-x86_64] Error 1

$ ps axwww | grep qemu | grep -v grep
26258 pts/0 Sl 0:00 x86_64-softmmu/qemu-system-x86_64 -qtest unix:/tmp/qtest-26256.sock,nowait -qtest-log /dev/null -qmp unix:/tmp/qtest-26256.qmp,nowait -pidfile /tmp/qtest-26256.pid -machine accel=qtest -display none -rtc clock=vm

The problem is that an assertion failure in a test case causes the test program to exit(2) without hitting the qtest cleanup.

Revision history for this message
Thomas Huth (th-huth) wrote :

I think this has been fixed sometime in the past already. Or can you still reproduce this problem with the latest version of QEMU?

Changed in qemu:
status: New → Incomplete
Revision history for this message
Cole Robinson (crobinso) wrote :

It appears this is fixed, I haven't seen it in a while

Changed in qemu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers