[RESOLVED] VirtFS (virtio-9p-pci) error: Parameter 'driver' expects device type

Bug #1130769 reported by Tim Comer on 2013-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

Getting error "Parameter 'driver' expects device type" when trying to share a file system with a guest.

Command line:
qemu-kvm
    -m 4096 -cpu host -smp 4,sockets=1
    -net nic,model=virtio,macaddr=00:00:00:00:00:00 -net tap,ifname=tap0,script=no,downscript=no
    -rtc base=localtime
    -drive file=/vm/VM.img,cache=none,if=virtio
    -curses
    -boot menu=off
    -fsdev fsdriver,id=fsdev-fs0,path=/srv/files,security_model=passthrough,writeout=writeout
    -device virtio-9p-pci,fsdev=fsdev-fs0,mount_tag=files

OS (host/guest): Gentoo
Kernel (host/guest): 3.7.5-hardened
CPU: AMD Opteron(TM) Processor 6272 (host: 16 cores, guest: 4)
Arch (host/guest): x86_64
Version: QEMU emulator version 1.2.2 (qemu-kvm-1.2.0), Copyright (c) 2003-2008 Fabrice Bellard
Package: app-emulation/qemu-1.2.2-r3

-no-kvm-irqchip did not have effect
-no-kvm-pit did not have effect other than "Warning: KVM PIT can no longer be disabled separately."
-no-kvm did not work with "Could not allocate dynamic translator buffer"

Tim Comer (comer) on 2013-02-20
no longer affects: qemu (Gentoo Linux)
M. Mohan Kumar (mohan-6) wrote :

-fsdev can take local, handle and proxy. Could you please use try with one of them?

Tim Comer (comer) wrote :

Same result:

    -fsdev local,id=fsdev-fs0,path=/srv/files,security_model=passthrough,writeout=immediate
    -device virtio-9p-pci,fsdev=fsdev-fs0,mount_tag=files

    qemu-kvm: -device virtio-9p-pci,fsdev=fsdev-fs0,mount_tag=files: Parameter 'driver' expects device type

Same result with a "shortcut" argument:
    qemu-kvm: -virtfs local,id=fsdev-fs0,path=/srv/files,security_model=passthrough,writeout=immediate,mount_tag=files: Parameter 'driver' expects device type

Daniel Berrange (berrange) wrote :

I wonder if the Gentoo build has got virtio-9p enabled at all. This kind of error message is the sort of thing QEMU often prints for a feature like this is disabled at build time

Tim Comer (comer) wrote :

Is there any way to verify? I see "/lib64/modules/3.7.5-hardened/kernel/net/9p/9pnet_virtio.ko" - is that it?

Tim Comer (comer) wrote :

There's a USE flag for Gentoo's package "app-emulation/qemu":
virtfs Enable VirtFS support. See http://wiki.qemu.org/Documentation/9psetup

I'll try enabling it explicitly and see if it helps.

Tim Comer (comer) wrote :

It did!
So this issue is resolved.
Thanks!

summary: - VirtFS (virtio-9p-pci) error: Parameter 'driver' expects device type
+ [RESOLVED] VirtFS (virtio-9p-pci) error: Parameter 'driver' expects
+ device type
Changed in qemu:
status: New → Invalid
no longer affects: qemu-kvm (Gentoo Linux)
Doug Goldstein (cardoe) wrote :

I've updated the Gentoo docs for the flag to read:

Enable VirtFS via fsdev (host) and virtio-9p-pci (guest). See http://wiki.qemu.org/Documentation/9psetup

Hopefully that's a bit more clear that you need to enable that for this support.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers