1366x768 resolution missing

Bug #1054558 reported by StarBrilliant on 2012-09-22
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
QEMU
Wishlist
Unassigned
Debian
Confirmed
Unknown

Bug Description

I use ArchLinux with QEMU 1.2.0.
I found that 1366x768 resolution is missing, even if I use -vga std or -vga vmware.
I think that it is necessary to patch it into the source.
Also, why not add a command-line option to specify custom resolutions without patching the source? (I know that VirtualBox has a hidden option to add any resolution.)

Changed in debian:
status: Unknown → New
Javier Barroso (javibarroso) wrote :

Is there any workaround ?

Thanks

Javier Barroso (javibarroso) wrote :

I tried it , but did not get the correct resolution. It takes 1280x768 (black space on both sides)

Thank you!

edmon (bozhan-abv) wrote :

I'm using winXP and win7 as guest with this setup and i have 1366x768, but i run it with virt-manager and this is in ps.

qemu-system-x86_64 -enable-kvm -name Windows7 -S -machine pc-i440fx-2.0,accel=kvm,usb=off -cpu Westmere,+invpcid,+erms,+bmi2,+smep,+avx2,+bmi1,+fsgsbase,+abm,+rdtscp,+pdpe1gb,+rdrand,+f16c,+avx,+osxsave,+xsave,+tsc-deadline,+movbe,+pcid,+pdcm,+xtpr,+fma,+tm2,+est,+vmx,+ds_cpl,+monitor,+dtes64,+pclmuldq,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 2048 -realtime mlock=off -smp 4,sockets=4,cores=1,threads=1 -uuid c074b8c6-9baa-49e4-b09d-553cc75e3345 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Windows7.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/var/lib/libvirt/images/Windows7.img,if=none,id=drive-ide0-0-0,format=raw -device ide-hd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive if=none,id=drive-ide0-0-1,readonly=on,format=raw -device ide-cd,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -netdev tap,fd=24,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:2d:e1:e5,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device usb-tablet,id=input0 -spice port=5900,addr=127.0.0.1,disable-ticketing,seamless-migration=on -k en-us -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,vgamem_mb=16,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5 -msg timestamp=o

Javier Barroso (javibarroso) wrote :

Thanks you, I will test with virt-manager.

I'm using a windows 8.1 installation. Seems like it need wqhl drivers, and The driver I found [1] did not work for this resolution.

Maybe I should test compiling seabios as commented on that blog

Thanks you

[1] https://supervacuo.com/2014/sep/28/windows-81-qemu-custom-resolutions-qxl/

Changed in debian:
status: New → Confirmed
Thomas Huth (th-huth) on 2017-08-21
Changed in qemu:
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.