windows xp sp3 setup blank screen on boot

Bug #1013888 reported by Michael Sabino on 2012-06-15
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Unassigned

Bug Description

When attempting to run Windows XP SP3 setup in qemu on a Lubuntu host with the following kernel:

Linux michael-XPS-M1530 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Qemu does not get past a blank screen after "Setup is inspecting your computer's hardware configuration"

Qemu 1.0.1 - Doesn't have a problem
Qemu 1.1.0 - has the problem
Qemu master commit eb2aeacf983a2a88a2b31e8fee067c38bd10abd3 - has the problem

qemu-system-x86_64 -L ../path/to/bios -cdrom winxp.iso -hda winxp.img -boot d

where ../path/to/bios is the location of the pc-bios files from that version of qemu

Luigi Tarenga (luigi-tarenga) wrote :

hi,
same problem on centos 6.2 with vanilla kernel 3.4.2.
I compiled qemu 1.0.1 from source and qemu 1.1.0 from source.

/opt/qemu-1.0.1/bin/qemu-system-i386 -m 2048 -cdrom Win_XP_Pro_SP3.iso -hda test.winXP.qcow2 : works

/opt/qemu-1.1.0/bin/qemu-system-i386 -m 2048 -cdrom Win_XP_Pro_SP3.iso -hda test.winXP.qcow2 : hangs

/opt/qemu-1.1.0/bin/qemu-system-i386 -m 2048 -cdrom Win_XP_Pro_SP3.iso -hda test.winXP.qcow2 -L /opt/qemu-1.0.1/data/ : hangs and on stderr give: Could not open option rom 'kvmvapic.bin': No such file or directory

/opt/qemu-1.1.0/bin/qemu-system-i386 -m 2048 -cdrom Win_XP_Pro_SP3.iso -hda test.winXP.qcow2 -L /opt/qemu-1.0.1/data/ -cpu qemu32,-apic : hangs

regards
Luigi

On Fri, Jun 15, 2012 at 11:49:36PM -0000, Michael Sabino wrote:
> Qemu 1.0.1 - Doesn't have a problem
> Qemu 1.1.0 - has the problem
> Qemu master commit eb2aeacf983a2a88a2b31e8fee067c38bd10abd3 - has the problem

I was also able to reproduce with commit:

eb2aeacf983a2a88a2b31e8fee067c38bd10abd3

The problem appears to have been fixed upstream though. A reverse bisect
points to this patch being the fix:

commit c52acf60b6c12ff5eb58eb6ac568c159ae0c8737
Author: Pavel Hrdina <email address hidden>
Date: Wed Jun 13 15:43:11 2012 +0200

    fdc: fix implied seek while there is no media in drive

    The Windows uses 'READ' command at the start of an instalation
    without checking the 'dir' register. We have to abort the transfer
    with an abnormal termination if there is no media in the drive.

    Signed-off-by: Pavel Hrdina <email address hidden>
    Signed-off-by: Kevin Wolf <email address hidden>

Please try your scenario again using that commit, and if all if it does the
trick we'll get it included in the next stable-1.1 release.

>
> --
> You received this bug notification because you are a member of qemu-
> devel-ml, which is subscribed to QEMU.
> https://bugs.launchpad.net/bugs/1013888
>
> Title:
> windows xp sp3 setup blank screen on boot
>
> Status in QEMU:
> New
>
> Bug description:
> When attempting to run Windows XP SP3 setup in qemu on a Lubuntu host
> with the following kernel:
>
> Linux michael-XPS-M1530 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10
> 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
>
> Qemu does not get past a blank screen after "Setup is inspecting your
> computer's hardware configuration"
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/qemu/+bug/1013888/+subscriptions
>

Luigi Tarenga (luigi-tarenga) wrote :

I confirm it works.
just compiled from commit c52acf60b6c12ff5eb58eb6ac568c159ae0c8737.
Windows XP SP3 installation iso boot and start installation process.

I tested both i368-softmmu and x86_64-softmmu targets.

thanks
Luigi

Johannes Schauer (josch) wrote :

The bug also applies to Debian Qemu 1.1.0

Adding the changes of commit c52acf60b6c12ff5eb58eb6ac568c159ae0c8737 on top of the 1.1.0 Debian package fixes the issue.

Which debian package do you mean? The fix is included is current debian qemu-kvm 1.1.0+dfsg-3 release. qemu package in debian does not have this fix however.

Thomas Huth (th-huth) wrote :

Marking this bug as fixed, according to comment #4 and #5

Changed in qemu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers