-dtb option searches instead of using a file in the current directory

Bug #1004205 reported by Michael Hope on 2012-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro QEMU
Fix Released
Undecided
Unassigned

Bug Description

If you try to run a KVM style guest using:

qemu-system-arm -M vexpress-a15 -drive file=guest.img,if=sd,cache=writeback -nographic -append 'root=/dev/mmcblk0p2 rw console=ttyAMA0 rootwait' -dtb *.dtb -kernel vmlinuz* -initrd initrd*

then qemu fails with:

Couldn't open dtb file rtsm_ve-cortex_a15x2.dtb

strace shows that QEMU tries to open /usr/share/qemu/rtsm_ve-cortex_a15x2.dtb instead of the one in the current directory. This is inconsistent with how the kernel and initrd are found. Adding a './*.dtb' works around the problem.

Peter Maydell (pmaydell) wrote :

Yes, it's inconsistent with -kernel and -initrd, but it's consistent with how other existing QEMU targets look for dtb files, which is why it ended up this way for ARM too.

Peter Maydell (pmaydell) wrote :

I've submitted the following patch which fixes this:
http://patchwork.ozlabs.org/patch/161324/
but since it also changes the filename lookup behaviour for a lot of other files it's possible it might run into resistance. We'll see.

Peter Maydell (pmaydell) on 2012-07-04
Changed in qemu-linaro:
status: New → Confirmed
Peter Maydell (pmaydell) on 2012-07-16
Changed in qemu-linaro:
milestone: none → 2012.08
Peter Maydell (pmaydell) wrote :

This patch was accepted upstream and has now made its way into qemu-linaro git; it will be in 2012.08.

Changed in qemu-linaro:
status: Confirmed → Fix Committed
Peter Maydell (pmaydell) on 2012-08-16
Changed in qemu-linaro:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers