Branches diverged message is confusing to gui users.

Bug #419277 reported by Stuart P. Bentley on 2009-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QBzr
Medium
Unassigned
TortoiseBZR
Undecided
Unassigned

Bug Description

When hitting update on a divergent branch, I get this output:

"Connected (version 2.0, client Twisted)
Authentication (publickey) successful!
Secsh channel 1 opened."
(red text) "bzr: ERROR: These branches have diverged. Use the missing command to see how."
(black text) "Use the merge command to reconcile them."

A few things:
1. "the missing command"? What?
2. Why is there a message saying what command to use *after* that one?
3. Shouldn't TortoiseBZR have a Merge function in the UI?

INADA Naoki (songofacandy) wrote :

1 and 2 is in qbzr area.
3 is TortoiseBZR's problem, but merge command have been supported since bzr-1.18.1.
Please use bzr-1.18.1 or after.

Changed in tortoisebzr:
status: New → Fix Released
summary: - Merge has weird presentation
+ Branches diverged message is confusing to gui users.
Changed in qbzr:
importance: Undecided → Medium
status: New → Confirmed
Alexander Belchenko (bialix) wrote :

Stuart,

"A few things:
1. "the missing command"? What?
2. Why is there a message saying what command to use *after* that one?"

These things come from bzr itself, qbzr dialogs just invokes bzr commands behind the scene.

I'm not sure what should be proper fix in qbzr fro this.

Gary van der Merwe (garyvdm) wrote :

This should be easy to fix now with the InfoWidget. We should show a InfoWidget with the option to see the missing revisions with qlog, or merge (or land, when it becomes available in bzr)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers