bzr: ERROR: exceptions.UnicodeEncodeError: 'ascii'

Bug #1217371 reported by August Quint on 2013-08-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
QBzr
Medium
Alexander Belchenko

Bug Description

here is the full report:
bzr: ERROR: exceptions.UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 170: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/qbzr/lib/run.py", line 255, in set_cmd_help
    self.ui.help_browser.setHtml(html_utf8.decode('utf-8'))
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 170: ordinal not in range(128)

bzr 2.6.0dev3 on python 2.7.4 (linux2)
arguments: ['/usr/bin/bzr', 'qrun', '--ui-mode']
encoding: 'utf-8', fsenc: 'UTF-8', lang: 'de_DE.UTF-8'
plugins:
  bash_completion /usr/lib/python2.7/dist-packages/bzrlib/plugins/bash_completion [2.6.0dev3]
  changelog_merge /usr/lib/python2.7/dist-packages/bzrlib/plugins/changelog_merge [2.6.0dev3]
  explorer /usr/lib/python2.7/dist-packages/bzrlib/plugins/explorer [1.3.0]
  grep /usr/lib/python2.7/dist-packages/bzrlib/plugins/grep [2.6.0dev3]
  launchpad /usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad [2.6.0dev3]
  netrc_credential_store /usr/lib/python2.7/dist-packages/bzrlib/plugins/netrc_credential_store [2.6.0dev3]
  news_merge /usr/lib/python2.7/dist-packages/bzrlib/plugins/news_merge [2.6.0dev3]
  po_merge /usr/lib/python2.7/dist-packages/bzrlib/plugins/po_merge [2.6.0dev3]
  qbzr /usr/lib/python2.7/dist-packages/bzrlib/plugins/qbzr [0.23.0]
  weave_fmt /usr/lib/python2.7/dist-packages/bzrlib/plugins/weave_fmt [2.6.0dev3]
------------------------------------
what I did:
in the Bazaar Explorer I double-clicked on a project.
in the next page I clicked on 'Alle' (=all commands)
in the next dialog i check the box :'versteckte Befehle zeigen' (=show hidden commands)
and then the error-message appears.

I can reproduce the error.
Do you need further information?

hth
AugustQ

Alexander Belchenko (bialix) wrote :

Which command you have selected in "Command" combo list box?

Changed in qbzr:
status: New → Incomplete
Alexander Belchenko (bialix) wrote :

August, can you try attached patch for qbzr plugin, please?

Alexander,

i have not selected any command in the list box, i simply checked the
box 'show hidden commands'.

August

Am Dienstag, den 27.08.2013, 14:20 +0000 schrieb Alexander Belchenko:
> Which command you have selected in "Command" combo list box?
>
> ** Changed in: qbzr
> Status: New => Incomplete
>

Alexander Belchenko (bialix) wrote :

I can't reproduce it unfortunately. But I have possible patch. If you are able to test it - that would be great.

Alexander Belchenko (bialix) wrote :

I've merged my patch into trunk. I hope it does help to fix this problem.

Changed in qbzr:
status: Incomplete → Fix Released
importance: Undecided → Medium
assignee: nobody → Alexander Belchenko (bialix)
milestone: none → 0.23.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers