QT4/pyqt4 support depreciated in Ubuntu 20

Bug #1900112 reported by James Ladyman
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qbrz
High
Robert Ladyman

Bug Description

The latest versions of Debian have removed qt4 and pyqt4 and this has now filtered downstream to Ubuntu 20 (and Mint 20 that's based on it) meaning qbzr and qbrz will stop working. Indeed qbzr has been removed from Ubuntu 20's repos as far as I can tell. qt5 is still available so it can be ported.

Revision history for this message
Robert Ladyman (saccadic-masking) wrote :

Right. Glad I did all that work (heh). I'll move it to pyside2 then and see if that helps (it should then be usable with Qt5).

Changed in qbrz:
importance: Undecided → High
assignee: nobody → Robert Ladyman (saccadic-masking)
status: New → Confirmed
Revision history for this message
Robert Ladyman (saccadic-masking) wrote :

Trunk is now converted to PyQt5 (not pyside2) - tests pass but some more work is needed. The old PyQt4 is now in:

https://code.launchpad.net/~saccadic-masking/qbrz/qbrz_pyqt4

Changed in qbrz:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers