Qarte ne se lance pas :ImportError: libQt5Svg.so.5

Bug #1681252 reported by umanu on 2017-04-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Qarte
Undecided
Unassigned

Bug Description

Bonjour, je suis sous archlinux (cf log plus bas)

Le paquet aur n'est plus à jour et me notifiait déjà le même bug.
J'ai don réinstallé qarte depuis la dernière archive tar.gz.

Quand je lance qarte en mode debug, voic ce que j'obtiens en sortie :

qarte -d
19:51:43: INFO - qarte Qarte-3.6.1
19:51:43: INFO - qarte Python 3.6.0 on Linux-4.10.8-1-ARCH-x86_64-with-arch
19:51:43: INFO - qarte File system encoding: utf-8
19:51:43: INFO - qarte System encoding: utf-8
19:51:43: INFO - qarte Locale encoding: ('fr_FR', 'UTF-8')
Traceback (most recent call last):
  File "/usr/bin/qarte", line 114, in <module>
    from core import Core
  File "/usr/share/qarte/core.py", line 28, in <module>
    from gui.mainui import MainUi
  File "/usr/share/qarte/gui/mainui.py", line 32, in <module>
    from .VWidgets_qt5.vlineedit import VLineEdit
  File "/usr/share/qarte/gui/VWidgets_qt5/vlineedit.py", line 35, in <module>
    from PyQt5.QtSvg import QSvgRenderer
ImportError: libQt5Svg.so.5: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type.

Me manque-t-il un paquet ou est-ce que le lien pointe vers un dossier/fichier inexistant ?

VinsS (vincent-vandevyvre) wrote :

Certaines distributions fournissent PyQt5 en paquets séparés.

C'est le cas de Debian et vraisemblablement de ArchLinux

Qarte dépend de

* python3-PyQt5
* python3-PyQt5.qtsvg

Il faudra le signaler au mainteneur du paquet Arch.

umanu (umanu) wrote :

merci pour la réponse.
Sous arch, j'ai l'ensemble de ces paquets d'installés :

extra/pyqt5-common 5.8-2 [installed]
    Common PyQt files shared between python-pyqt5 and python2-pyqt5
extra/python-pyqt5 5.8-2 [installed]
    A set of Python 3.x bindings for the Qt5 toolkit
extra/python2-pyqt5 5.8-2 [installed]
    A set of Python 2.x bindings for the Qt5 toolkit
community/python-qtpy 1.2.1-1 [installed]
    Provides an uniform layer to support PyQt5, PyQt4 and PySide with a single
    codebase
community/python2-qtpy 1.2.1-1 [installed]
    Provides an uniform layer to support PyQt5, PyQt4 and PySide with a single
    codebase

Ce dernier :

https://www.archlinux.org/packages/extra/x86_64/python-pyqt5/files/

me semble correspondre peu ou proue à ceux nécessaires à la Debian.

Je fait quand même remonter le problème au mainteneur du paquet aur.

Merci.

Emm88 (emm88) wrote :

On peut fermer ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers