[ADT test failure] linux: ubuntu_qrt_apparmor.test-apparmor.py -- ONEXEC - check current 'unconfined' != expected

Bug #1528230 reported by Andy Whitcroft on 2015-12-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AppArmor
Medium
Tyler Hicks
QA Regression Testing
Undecided
Unassigned
apparmor (Ubuntu)
Medium
Tyler Hicks
Xenial
Medium
Tyler Hicks

Bug Description

[Impact]

The AppArmor regression tests are ran as part of the kernel SRU verification process. One of the tests, onexec.sh, contains a racy section that introduces intermittent failures. Such failures introduce doubt in the kernel SRU process and generate additional work to verify that the failures can be ignored.

[Test Case]

Since the fix is to the onexec.sh test itself, the best test case is to simply run the test. The QRT test-apparmor.py script runs this test, among many others, and should be used for verification.

[Regression Potential]

None. The fix is to the test and does not affect code that is user-facing.

[Original Report]

New ADT test failure in Vivid:

  running onexec
  ONEXEC - check current 'unconfined' != expected '/tmp/testlibIUFsmN/source/vivid/apparmor-2.9.1/tests/regression/apparmor/onexec'
  Fatal Error (onexec): Unable to run test sub-executable

Full log:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-vivid/vivid/ppc64el/l/linux/20151218_175610@/log.gz

Andy Whitcroft (apw) on 2015-12-21
description: updated
Changed in linux (Ubuntu):
status: New → Confirmed
Steve Beattie (sbeattie) on 2016-04-28
tags: added: apparmor
tags: added: qart
tags: removed: qart
Tyler Hicks (tyhicks) wrote :

I think this was likely a problem (race condition) in the upstream test itself. I think I've been able to eliminate any races in the test with upstream commits r3488 and r3489.

Changed in apparmor:
status: New → Fix Committed
assignee: nobody → Tyler Hicks (tyhicks)
importance: Undecided → Medium
milestone: none → 2.11
Tyler Hicks (tyhicks) wrote :

This fix was released in yakkety via 2.10.95-4ubuntu2.

Changed in apparmor (Ubuntu):
status: New → Fix Released
importance: Undecided → Medium
assignee: nobody → Tyler Hicks (tyhicks)
Changed in apparmor (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Tyler Hicks (tyhicks)
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Xenial):
status: New → Invalid
Changed in qa-regression-testing:
status: New → Invalid
Tyler Hicks (tyhicks) on 2016-07-28
description: updated

Hello Andy, or anyone else affected,

Accepted apparmor into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apparmor/2.10.95-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apparmor (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Tyler Hicks (tyhicks) wrote :

I've thoroughly tested apparmor 2.10.95-0ubuntu2.2 in xenial-proposed. I've verified that this bug is fixed (via QRT's test-apparmor.py, as mentioned in Test Case in the description) and I've also went through the AppArmor Test Plan (excluding the Ubuntu Touch specific tests):

  https://wiki.ubuntu.com/Process/Merges/TestPlans/AppArmor

The Test Plan includes running the entire set of upstream AppArmor tests, a number of integration tests, libvirt tests, LXC/LXD tests, docker.io tests, Snappy confinement tests, etc.

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

It looks like this SRU has caused a regression in the autopkgtests for mysql-5.7.

http://autopkgtest.ubuntu.com/packages/m/mysql-5.7/xenial/i386/

tags: added: verification-failed
removed: verification-done
no longer affects: linux (Ubuntu Xenial)
no longer affects: linux (Ubuntu)
Seth Arnold (seth-arnold) wrote :

Brian, is the dmesg output from the machine in question captured anywhere?

Thanks

Tyler Hicks (tyhicks) wrote :

Brian, I ran the mysql-5.7 autopkgtests with and without the new apparmor packages and both resulted in the same test failure. I'm fairly sure that the failure was introduced with the new mysql-5.7 packages (5.7.13-0ubuntu0.16.04.2) rather than with the new apparmor packages.

Tyler Hicks (tyhicks) wrote :

I'm attaching the diff between the test runs with the old apparmor packages and with the new apparmor packages to show that they both fail the same. This leads me to believe that the new mysql-5.7 version is what introduced the test failure.

Tyler Hicks (tyhicks) wrote :

I spoke with Brian in #ubuntu-devel and he agreed that it is alright to mark this SRU as verification-done based on the two most recent comments above.

tags: added: verification-done
removed: verification-failed
Christian Boltz (cboltz) on 2017-01-10
Changed in apparmor:
status: Fix Committed → Fix Released
Steve Beattie (sbeattie) wrote :

This was fixed in Ubuntu 16.04 lts in apparmor 2.10.95-0ubuntu2.2; closing that task.

Changed in apparmor (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers