New tests add imports above from __future__ import

Bug #373978 reported by ryan.freckleton on 2009-05-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pythoscope
Medium
Michal Kwiatkowski

Bug Description

When running pythoscope to generate additional test cases, if the test module already contains a from __future__ import, new imports from pythoscope (for example, importing nose.tools) is put before other imports. This is a syntax error, since from __future__ import has to be at the top of the file.

Michal Kwiatkowski (ruby) wrote :

Right, I forgot about the __future__ imports, thanks!

Changed in pythoscope:
importance: Undecided → Medium
milestone: none → 0.4.2-dependency-cleanup
status: New → Confirmed
summary: - New tests adds imports above from __future__ iport
+ New tests add imports above from __future__ import
Michal Kwiatkowski (ruby) wrote :

Fixed in trunk r300.

Changed in pythoscope:
status: Confirmed → Fix Committed
assignee: nobody → Michal Kwiatkowski (ruby)
Michal Kwiatkowski (ruby) wrote :

Fix released in Pythoscope 0.4.2.

Changed in pythoscope:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers