remove py26 support

Bug #1519510 reported by Steve Martinelli on 2015-11-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Astara
Undecided
sonu
Cognitive
In Progress
Undecided
zhangyangyang
Designate
Undecided
Nguyen Van Trung
Entropy
Undecided
zhangyangyang
First App Application For OpenStack
Undecided
Yuiko Takada
Glance Client
Undecided
Shu Muto
Monasca
In Progress
Undecided
Shu Muto
Nodepool
In Progress
Undecided
zhangyangyang
PBR
Undecided
zhangyangyang
Python client for HP OneView
Undecided
Shu Muto
Python client library for Sahara
Medium
Shu Muto
Python client library for Zaqar
Undecided
Md Nadeem
Sticks
In Progress
Undecided
zhangyangyang
Zuul
In Progress
Undecided
zhangyangyang
cathead
Undecided
zhangyangyang
cloudkitty
Undecided
yuanying
congress
Undecided
Yuiko Takada
cue-dashboard
Undecided
Unassigned
daisycloud-core
Undecided
zhangyangyang
dox
Undecided
zhangyangyang
grafyaml
In Progress
Undecided
zhangyangyang
networking-brocade
Undecided
zhangyangyang
networking-fortinet
Undecided
zhangyangyang
networking-hpe
Undecided
zhangyangyang
nova-solver-scheduler
Undecided
zhangyangyang
openstack-nose
Undecided
zhangyangyang
oslo.privsep
Undecided
sonu
pyghmi
Undecided
zhangyangyang
python-barbicanclient
Undecided
Rico Lin
python-cinderclient
Undecided
Shu Muto
python-congressclient
Undecided
Shu Muto
python-designateclient
Undecided
sonu
python-evoqueclient
Undecided
Rico Lin
python-heatclient
Medium
Rico Lin
python-kiteclient
In Progress
Undecided
Sai Kiran
python-magnetodbclient
Undecided
Sai Kiran
python-magnumclient
Undecided
Shu Muto
python-manilaclient
Undecided
Valeriy Ponomaryov
python-mistralclient
Undecided
Rico Lin
python-muranoclient
Undecided
Rico Lin
python-novaclient
Undecided
Shu Muto
python-openstackclient
High
Steve Martinelli
python-rackclient
Undecided
Sai Kiran
python-searchlightclient
Undecided
Shu Muto
python-senlinclient
Medium
Shu Muto
python-solumclient
Undecided
Rico Lin
python-swiftclient
Undecided
Rico Lin
python-tackerclient
Medium
Rico Lin
python-tox
New
Undecided
sato wataru
python-troveclient
Undecided
Rico Lin
python-watcherclient
Low
Rico Lin
requests-mock
Undecided
zhangyangyang
sqlalchemy-migrate
Undecided
zhangyangyang
steth
Undecided
zhangyangyang
swiftonfile
Undecided
zhangyangyang
swiftonhpss
Undecided
zhangyangyang
tuskar-ui
Undecided
Yuiko Takada

Bug Description

as of mitaka, the infra team won't have the resources available to reasonably test py26, also the oslo team is dropping py26 support from their libraries. sine we rely on oslo for a lot of our work, and depend on infra for our CI, we should drop py26 support too.

Terry Howe (thowe-g) on 2015-11-24
Changed in python-openstackclient:
status: New → Confirmed
Steve Martinelli (stevemar) wrote :

not sure why the patches aren't being linked these days: https://review.openstack.org/#/c/249451/

Changed in python-openstackclient:
importance: Undecided → High
assignee: nobody → Steve Martinelli (stevemar)

Reviewed: https://review.openstack.org/249451
Committed: https://git.openstack.org/cgit/openstack/python-openstackclient/commit/?id=510a4d9674a61b4bc994138790452fad45616c10
Submitter: Jenkins
Branch: master

commit 510a4d9674a61b4bc994138790452fad45616c10
Author: Steve Martinelli <email address hidden>
Date: Tue Nov 24 17:08:04 2015 -0500

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I66d168ecc755a3ea0e01d5b6344d06d9e0d1378b
    Closes-Bug: 1519510

Changed in python-openstackclient:
status: Confirmed → Fix Committed
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-cinderclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-ceilometerclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Changed in python-glanceclient:
status: New → In Progress
assignee: nobody → Shu Muto (shu-mutou)
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-novaclient:
status: New → In Progress
assignee: nobody → Shu Muto (shu-mutou)
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-magnumclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-saharaclient:
status: New → In Progress
assignee: nobody → Shu Muto (shu-mutou)
Changed in python-zaqarclient:
assignee: nobody → MD NADEEM (mail2nadeem92)
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-senlinclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/252270

Changed in python-zaqarclient:
status: New → In Progress
Shu Muto (shu-mutou) on 2015-12-02
Changed in python-neutronclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Changed in python-manilaclient:
assignee: nobody → Valeriy Ponomaryov (vponomaryov)
Qiming Teng (tengqim) on 2015-12-02
Changed in python-senlinclient:
importance: Undecided → Medium
Rico Lin (rico-lin) on 2015-12-02
Changed in python-heatclient:
assignee: nobody → Rico Lin (rico-lin)
Changed in python-heatclient:
status: New → In Progress
Qiming Teng (tengqim) on 2015-12-02
Changed in python-heatclient:
importance: Undecided → Medium

Change abandoned by Fei Long Wang (<email address hidden>) on branch: master
Review: https://review.openstack.org/252270

Reviewed: https://review.openstack.org/252252
Committed: https://git.openstack.org/cgit/openstack/python-senlinclient/commit/?id=0598f6fa8d8658e77ebfbac2eb6d5a575d579124
Submitter: Jenkins
Branch: master

commit 0598f6fa8d8658e77ebfbac2eb6d5a575d579124
Author: shu-mutou <email address hidden>
Date: Wed Dec 2 17:27:08 2015 +0900

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I31bb7a18a1793b2664cc924777801e16e4105192
    Closes-Bug: 1519510

Changed in python-senlinclient:
status: In Progress → Fix Committed
Rico Lin (rico-lin) on 2015-12-02
Changed in python-swiftclient:
assignee: nobody → Rico Lin (rico-lin)

Fix proposed to branch: master
Review: https://review.openstack.org/252435

Changed in python-swiftclient:
status: New → In Progress

Reviewed: https://review.openstack.org/252236
Committed: https://git.openstack.org/cgit/openstack/python-magnumclient/commit/?id=a603e63f59fcf60009c6f987229b959562357344
Submitter: Jenkins
Branch: master

commit a603e63f59fcf60009c6f987229b959562357344
Author: shu-mutou <email address hidden>
Date: Wed Dec 2 16:58:00 2015 +0900

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I8c1e5765228382c9982883320568fe729d0c35f8
    Closes-Bug: 1519510

Changed in python-magnumclient:
status: In Progress → Fix Committed
Rico Lin (rico-lin) on 2015-12-02
Changed in python-muranoclient:
assignee: nobody → Rico Lin (rico-lin)

Fix proposed to branch: master
Review: https://review.openstack.org/252456

Changed in python-muranoclient:
status: New → In Progress
Rico Lin (rico-lin) on 2015-12-02
Changed in python-solumclient:
assignee: nobody → Rico Lin (rico-lin)
Changed in python-watcherclient:
assignee: nobody → Rico Lin (rico-lin)

Fix proposed to branch: master
Review: https://review.openstack.org/252464

Changed in python-watcherclient:
status: New → In Progress
Rico Lin (rico-lin) wrote :
Changed in python-solumclient:
status: New → In Progress
Changed in python-troveclient:
assignee: nobody → Rico Lin (rico-lin)

Fix proposed to branch: master
Review: https://review.openstack.org/252470

Changed in python-troveclient:
status: New → In Progress
Rico Lin (rico-lin) on 2015-12-02
Changed in python-barbicanclient:
assignee: nobody → Rico Lin (rico-lin)

Fix proposed to branch: master
Review: https://review.openstack.org/252473

Changed in python-barbicanclient:
status: New → In Progress
Rico Lin (rico-lin) on 2015-12-02
Changed in python-mistralclient:
assignee: nobody → Rico Lin (rico-lin)
Rico Lin (rico-lin) on 2015-12-02
Changed in python-tackerclient:
assignee: nobody → Rico Lin (rico-lin)
Changed in python-tuskarclient:
assignee: nobody → Rico Lin (rico-lin)
no longer affects: python-tuskarclient
Rico Lin (rico-lin) on 2015-12-02
Changed in python-evoqueclient:
assignee: nobody → Rico Lin (rico-lin)

Fix proposed to branch: master
Review: https://review.openstack.org/252486

Changed in python-evoqueclient:
status: New → In Progress
Rico Lin (rico-lin) on 2015-12-02
Changed in python-rackclient:
assignee: nobody → Rico Lin (rico-lin)
Rico Lin (rico-lin) wrote :
Changed in python-mistralclient:
status: New → In Progress
Changed in python-rackclient:
assignee: Rico Lin (rico-lin) → nobody
Rico Lin (rico-lin) wrote :
Changed in python-tackerclient:
status: New → In Progress

Reviewed: https://review.openstack.org/252278
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=7ff7e76d21e441efd611abf8ca6de96c15d9bb35
Submitter: Jenkins
Branch: master

commit 7ff7e76d21e441efd611abf8ca6de96c15d9bb35
Author: shu-mutou <email address hidden>
Date: Wed Dec 2 18:08:23 2015 +0900

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I62db55ee1a9e7564a10a7284bd0e401b2cdbc580
    Closes-Bug: 1519510
    Depends-On: I4a2f860e8138bddb032418ee555e07a6fa0a3f3e

Changed in python-neutronclient:
status: In Progress → Fix Committed

Change abandoned by Shu Muto (<email address hidden>) on branch: master
Review: https://review.openstack.org/252239

sonu (sonu-bhumca11) on 2015-12-03
Changed in python-designateclient:
assignee: nobody → sonu (sonu-bhumca11)

Fix proposed to branch: master
Review: https://review.openstack.org/252733

Changed in python-designateclient:
status: New → In Progress

Reviewed: https://review.openstack.org/252224
Committed: https://git.openstack.org/cgit/openstack/python-heatclient/commit/?id=32397cbd66bc7573e227cb49da1039f137c5f545
Submitter: Jenkins
Branch: master

commit 32397cbd66bc7573e227cb49da1039f137c5f545
Author: ricolin <email address hidden>
Date: Wed Dec 2 15:17:05 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510

    Change-Id: I680043c48c75a50b3ef8eed4f22e97dca029c477

Changed in python-heatclient:
status: In Progress → Fix Committed
Akihiro Motoki (amotoki) on 2015-12-03
Changed in python-neutronclient:
importance: Undecided → Medium
milestone: none → 4.0.0

Reviewed: https://review.openstack.org/252464
Committed: https://git.openstack.org/cgit/openstack/python-watcherclient/commit/?id=90d98a6769cceebe84646dcb0029d2eda7611551
Submitter: Jenkins
Branch: master

commit 90d98a6769cceebe84646dcb0029d2eda7611551
Author: ricolin <email address hidden>
Date: Wed Dec 2 23:41:26 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510

    Change-Id: I72b6e6cb881f3ce34b61020c0b6614de8335badd

Changed in python-watcherclient:
status: In Progress → Fix Committed

This issue was fixed in the openstack/python-openstackclient 2.0.0 release.

Changed in python-openstackclient:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/252233
Committed: https://git.openstack.org/cgit/openstack/python-ceilometerclient/commit/?id=401c0f3e201cfab6dfafcf25ad64fd7953f9cae5
Submitter: Jenkins
Branch: master

commit 401c0f3e201cfab6dfafcf25ad64fd7953f9cae5
Author: shu-mutou <email address hidden>
Date: Wed Dec 2 16:50:27 2015 +0900

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I2218cf3464a9c1667f8eb812a519b2bc3ffe4d0d
    Closes-Bug: 1519510

Changed in python-ceilometerclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/252270
Committed: https://git.openstack.org/cgit/openstack/python-zaqarclient/commit/?id=66b703c69e91305a4b8018882dfe9426ba5da58b
Submitter: Jenkins
Branch: master

commit 66b703c69e91305a4b8018882dfe9426ba5da58b
Author: Md Nadeem <email address hidden>
Date: Wed Dec 2 17:57:43 2015 +0900

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I6420a95a58c85830412ae5792208d952116ca7e6
    Closes-Bug: 1519510

Changed in python-zaqarclient:
status: In Progress → Fix Committed
sato wataru (watari53) on 2015-12-04
affects: tox → ubuntu
Changed in ubuntu:
assignee: nobody → sato wataru (watari53)
affects: ubuntu → python-tox

Reviewed: https://review.openstack.org/252733
Committed: https://git.openstack.org/cgit/openstack/python-designateclient/commit/?id=b34d20dbcc93ef1db3e95a5641d4208b6d9c03c8
Submitter: Jenkins
Branch: master

commit b34d20dbcc93ef1db3e95a5641d4208b6d9c03c8
Author: sonu.kumar <email address hidden>
Date: Thu Dec 3 09:24:43 2015 +0530

    Remove py26 support from designateclient

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: Id322ec683643c817bef1de43519394808cc64072
    Closes-Bug: #1519510

Changed in python-designateclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/252246
Committed: https://git.openstack.org/cgit/openstack/python-saharaclient/commit/?id=4fdb92509145eed6c7911bba95c8816ac7c112f8
Submitter: Jenkins
Branch: master

commit 4fdb92509145eed6c7911bba95c8816ac7c112f8
Author: shu-mutou <email address hidden>
Date: Wed Dec 2 17:18:50 2015 +0900

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. since we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I7920b554f541c2c40a8a3145662a0eff7faadf2f
    Closes-Bug: 1519510

Changed in python-saharaclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/252232
Committed: https://git.openstack.org/cgit/openstack/python-cinderclient/commit/?id=98b4a3d32ff8b55c2751d43f99b87f5b049d083b
Submitter: Jenkins
Branch: master

commit 98b4a3d32ff8b55c2751d43f99b87f5b049d083b
Author: shu-mutou <email address hidden>
Date: Wed Dec 2 16:45:02 2015 +0900

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: Icf1b13b044de03705688df929ed74429879c6dd8
    Closes-Bug: 1519510

Changed in python-cinderclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/252461
Committed: https://git.openstack.org/cgit/openstack/python-solumclient/commit/?id=fedbaf4a909c667a566b17966130934fa7ea46dc
Submitter: Jenkins
Branch: master

commit fedbaf4a909c667a566b17966130934fa7ea46dc
Author: ricolin <email address hidden>
Date: Wed Dec 2 23:36:43 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510

    Change-Id: I7b202a5baa6e9520827022a545ffafa58578ddcd

Changed in python-solumclient:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/252456
Committed: https://git.openstack.org/cgit/openstack/python-muranoclient/commit/?id=f5f92e44820d947faac7ca621e60c6b5cbfafe8f
Submitter: Jenkins
Branch: master

commit f5f92e44820d947faac7ca621e60c6b5cbfafe8f
Author: ricolin <email address hidden>
Date: Wed Dec 2 23:29:05 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510

    Change-Id: I4997706a854e3a0e761776dbf0609e556c1d803d

Changed in python-muranoclient:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/252486
Committed: https://git.openstack.org/cgit/openstack/python-evoqueclient/commit/?id=9d226cd9fede3df28c0ec4b5ca68ff9318287adb
Submitter: Jenkins
Branch: master

commit 9d226cd9fede3df28c0ec4b5ca68ff9318287adb
Author: ricolin <email address hidden>
Date: Thu Dec 3 00:09:05 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510

    Change-Id: I6a229029dee2588833d5f70977c3d3af6ee998c2

Changed in python-evoqueclient:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/252473
Committed: https://git.openstack.org/cgit/openstack/python-barbicanclient/commit/?id=a80f7ea7a13150ee4558be523b651c8325dc2103
Submitter: Jenkins
Branch: master

commit a80f7ea7a13150ee4558be523b651c8325dc2103
Author: ricolin <email address hidden>
Date: Wed Dec 2 23:54:06 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510
    Depends-On: Ic8241e55b5f4e3d567156d4c1e8bf8a0303f6d29

    Change-Id: I4386dc70e3d467e31963d852726af78fbdbbba38

Changed in python-barbicanclient:
status: In Progress → Fix Released
sonu (sonu-bhumca11) on 2015-12-10
Changed in oslo.privsep:
assignee: nobody → sonu (sonu-bhumca11)
status: New → In Progress
Changed in python-cinderclient:
status: Fix Committed → Fix Released

Reviewed: https://review.openstack.org/252435
Committed: https://git.openstack.org/cgit/openstack/python-swiftclient/commit/?id=cffdc9d3579d764500f613b74eaaba14520313bd
Submitter: Jenkins
Branch: master

commit cffdc9d3579d764500f613b74eaaba14520313bd
Author: ricolin <email address hidden>
Date: Wed Dec 2 22:53:00 2015 +0800

    Remove py26 support

    As of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.
    Closes-Bug: 1519510
    Depends-On: I37116731db11449d0c374a6a83a3a43789a19d5f

    Change-Id: I776847ce77dfe82880f34d0b7804514e5aed3f8d

Changed in python-swiftclient:
status: In Progress → Fix Released
sonu (sonu-bhumca11) on 2015-12-15
Changed in astara:
assignee: nobody → sonu (sonu-bhumca11)
status: New → In Progress
Shu Muto (shu-mutou) on 2015-12-15
Changed in python-searchlightclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Shu Muto (shu-mutou) on 2015-12-15
Changed in python-rackclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
assignee: Shu Muto (shu-mutou) → nobody
status: In Progress → New
Shu Muto (shu-mutou) on 2015-12-15
Changed in python-congressclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/257802

Changed in python-congressclient:
status: Confirmed → In Progress
Shu Muto (shu-mutou) on 2015-12-15
Changed in python-oneviewclient:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Shu Muto (shu-mutou) on 2015-12-15
Changed in monasca:
assignee: nobody → Shu Muto (shu-mutou)
status: New → In Progress
Changed in python-oneviewclient:
status: In Progress → Fix Released
Changed in astara:
status: In Progress → Fix Released
Qiming Teng (tengqim) on 2015-12-16
Changed in python-senlinclient:
status: Fix Committed → Fix Released
Sai Kiran (saikiran) on 2015-12-18
Changed in python-kiteclient:
assignee: nobody → Sai Kiran (saikiran)
Changed in python-magnetodbclient:
assignee: nobody → Sai Kiran (saikiran)
Changed in python-rackclient:
assignee: nobody → Sai Kiran (saikiran)
yuanying (ootsuka) on 2015-12-24
Changed in cloudkitty:
assignee: nobody → yuanying (ootsuka)
Changed in congress:
assignee: nobody → Yuiko Takada (takada-yuiko)
Changed in congress:
status: New → In Progress
Changed in faafo:
assignee: nobody → Yuiko Takada (takada-yuiko)
Changed in faafo:
status: New → In Progress
Changed in cloudkitty:
status: New → In Progress
Changed in futurist:
assignee: nobody → Yuiko Takada (takada-yuiko)
Changed in tuskar-ui:
assignee: nobody → Yuiko Takada (takada-yuiko)
Changed in tuskar-ui:
status: New → In Progress
Kenji Yasui (k-yasui) on 2015-12-24
Changed in cue-dashboard:
assignee: nobody → Kenji Yasui (k-yasui)
Changed in cue-dashboard:
status: New → In Progress
Kenji Yasui (k-yasui) on 2015-12-25
Changed in cue-dashboard:
assignee: Kenji Yasui (k-yasui) → nobody
Changed in python-rackclient:
status: New → In Progress
Changed in python-kiteclient:
status: New → In Progress
Changed in congress:
status: In Progress → Fix Released
Changed in python-troveclient:
status: In Progress → Fix Released
Akihiro Motoki (amotoki) on 2016-01-06
Changed in python-neutronclient:
status: Fix Committed → Fix Released
Changed in python-congressclient:
status: In Progress → Fix Released
Changed in python-glanceclient:
status: In Progress → Fix Released
gordon chung (chungg) on 2016-01-13
Changed in python-ceilometerclient:
status: Fix Committed → Fix Released
Changed in oslo.privsep:
status: In Progress → Fix Committed
no longer affects: futurist
Changed in python-manilaclient:
milestone: none → mitaka-2
status: New → Fix Committed
Changed in python-saharaclient:
milestone: none → 0.12.0
Changed in python-saharaclient:
importance: Undecided → Medium
status: Fix Committed → Fix Released
37 comments hidden view all 117 comments

This issue was fixed in the openstack/python-barbicanclient 4.0.0 release.

This issue was fixed in the openstack/python-zaqarclient 1.0.0 release.

Changed in python-tackerclient:
importance: Undecided → Medium

This issue was fixed in the openstack/python-tackerclient 0.3.0 release.

Changed in python-watcherclient:
importance: Undecided → Low
milestone: none → newton-1
status: Fix Committed → Fix Released

Change abandoned by Rico Lin (<email address hidden>) on branch: master
Review: https://review.openstack.org/252497

Change abandoned by Yuiko Takada Mori (<email address hidden>) on branch: master
Review: https://review.openstack.org/261170

Changed in python-heatclient:
milestone: none → 1.3.0

This issue was fixed in the openstack/networking-calico 1.2.0 release.

Changed in python-mistralclient:
status: In Progress → Fix Released
Changed in python-tackerclient:
status: In Progress → Fix Committed

This issue was fixed in the openstack/python-cinderclient 1.6.0 release.

This issue was fixed in the openstack/python-mistralclient 2.0.0 release.

This issue was fixed in the openstack/python-swiftclient 3.0.0 release.

This issue was fixed in the openstack/python-zaqarclient 1.0.0 release.

Fix proposed to branch: master
Review: https://review.openstack.org/422438

Changed in heat:
assignee: nobody → Tuan (tuanla)
status: New → In Progress
Thomas Herve (therve) on 2017-01-19
no longer affects: heat

This issue was fixed in the openstack/heat 8.0.0.0b3 development milestone.

This issue was fixed in the openstack/cloudkitty-dashboard 5.0.0 release.

Ken Giusti (kgiusti) on 2017-02-20
Changed in oslo.privsep:
status: Fix Committed → Fix Released
Akihiro Motoki (amotoki) on 2017-04-01
no longer affects: python-neutronclient
wangxiyuan (wangxiyuan) on 2017-05-18
Changed in python-zaqarclient:
status: Fix Committed → Fix Released
Changed in designate:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in swiftonfile:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in swiftonhpss:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in sticks:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in steth:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in sqlalchemy-migrate:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in cathead:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in cognitive:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in entropy:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/504843

Changed in pbr:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in pyghmi:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/504853

Changed in requests-mock:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in nodepool:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in zuul:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in daisycloud-core:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in dox:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in grafyaml:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in networking-brocade:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in networking-fortinet:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in networking-hpe:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress
Changed in nova-solver-scheduler:
status: New → In Progress
assignee: nobody → zhangyangyang (zhangyangyang)
Changed in openstack-nose:
assignee: nobody → zhangyangyang (zhangyangyang)
status: New → In Progress

Reviewed: https://review.openstack.org/504843
Committed: https://git.openstack.org/cgit/openstack-dev/pbr/commit/?id=558980151ac5c7fd17181e79ca402ab0a7317de0
Submitter: Jenkins
Branch: master

commit 558980151ac5c7fd17181e79ca402ab0a7317de0
Author: zhangyangyang <email address hidden>
Date: Mon Sep 18 12:00:30 2017 +0800

    Remove py26 support

    as of mitaka, the infra team won't have the resources available to
    reasonably test py26, also the oslo team is dropping py26 support
    from their libraries. sine we rely on oslo for a lot of our work,
    and depend on infra for our CI, we should drop py26 support too.

    Change-Id: I628f5a1463a893bfc16f795ef7144cd2376130de
    Closes-Bug: #1519510

Changed in pbr:
status: In Progress → Fix Released

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504853

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504844

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504841

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504837

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504832

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504835

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504790

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504783

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504781

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504779

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504777

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504595

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504596

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504589

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504594

Changed in designate:
assignee: zhangyangyang (zhangyangyang) → Nguyen Van Trung (trungnv)
gordon chung (chungg) on 2017-10-02
no longer affects: python-ceilometerclient

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504585

Change abandoned by zhangyangyang (<email address hidden>) on branch: master
Review: https://review.openstack.org/504597

Displaying first 40 and last 40 comments. View all 117 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers