[Network] Different behavior for access_as_external target

Bug #1728525 reported by Dongcan Ye on 2017-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-openstackclient
Fix Released
Undecided
Dongcan Ye

Bug Description

Using neutronclient and openstackclient for rbac policy have different behavior:
http://paste.openstack.org/show/624931/

In neutronclient, we may use "*" as default target_tenant if not pass target_tenant in CLI, but in openstackclient this is not allowed.

Dongcan Ye (hellochosen) on 2017-10-30
Changed in python-openstackclient:
assignee: nobody → Dongcan Ye (hellochosen)

Fix proposed to branch: master
Review: https://review.openstack.org/516211

Changed in python-openstackclient:
status: New → In Progress
Akihiro Motoki (amotoki) wrote :

The different behavior of neutron CLI and OSC itself is not a problem as these two CLIs are designed based on different concepts.

The problem is OSC implementation does not allow to provide a way to specify '*' as target_tenant (target_project). This is completely a bug in OSC. '*' can be a default value in the fix.

Reviewed: https://review.openstack.org/516211
Committed: https://git.openstack.org/cgit/openstack/python-openstackclient/commit/?id=9ca99b991947c5b932a0c916591cd71568f2ac17
Submitter: Zuul
Branch: master

commit 9ca99b991947c5b932a0c916591cd71568f2ac17
Author: Dongcan Ye <email address hidden>
Date: Sun Nov 5 01:16:48 2017 -0500

    Network: Add supports rbac target-all-projects

    Add a boolean option "target-all-projects",
    which allows creating rbac policy for all projects.

    Change-Id: Ie3af83a1bba7dd66e83b0595bb276bf8fd105831
    Closes-Bug: #1728525
    Closes-Bug: #1704834

Changed in python-openstackclient:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-openstackclient 3.13.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers