router show should include interfaces

Bug #1675489 reported by David Rabel on 2017-03-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-openstackclient
Fix Released
Wishlist
yanpuqing

Bug Description

"openstack router show" shows the external gateway info. It should also show information of connected interfaces.

Rui Chen (kiwik-chenrui) wrote :

Looks reasonable case, we have "router add port/subnet" command now, but can't show which interface had been set on specified router, neutron client have "neutron router-port-list <router>", we should implement it in OSC.

Akihiro Motoki (amotoki) wrote :

I think this is reasonable request. As a user, when debugging something, I usually type both commands "openstack router show" and "openstack port list --router" to know the detail of a specific router, so it would be nice if a list of interfaces is included in the output of 'openstack router show'.

I think necessary information on router interface (port) are: IP address, subnet ID (and port ID).
IP address is usually needed to ping to the router.
Subnet ID (or port ID) is required when we want to run "openstack port remove".
If the output is like "IP address: xxxx, subnet ID: xxxxx, port ID: xxxxx", users can know more detail of the port by "openstack port show".

The output format is one concern when we implement this.
Something like JSON blob might help us.
Another idea is to wrap lines with shorter width.
 | interfaces | - 10.1.1.1
 | | Port ID 7e72f486-784c-4c17-996b-e932ae9bc29c
 | | Subnet ID fdd13fb1-f264-4cf4-ba13-18e52ee44691
 | | - 192.168.20.254
 | | Port ID e4f1f43e-f1d6-4d5e-b2e3-144d464b9cdb
 | | Subnet ID 48ac1947-0299-4106-b8b8-634718e62567

To show this information, we need one extra call, but one extra would be okay as we do more calls for "show" commands.

Note that we already have a equivalent command of "neutron router-port-list". It is "openstack port list --router <router>".
Currently we don't have any "router" related keyword in the help message, so it is sometimes difficult to find the command.

Rui Chen (kiwik-chenrui) wrote :

It might be helpful, "port list --router <router> --long" will show device owner of the port, looks like: network:router_interface, network:router_gateway, so it work out your case?

Dean Troyer (dtroyer) on 2017-04-28
Changed in python-openstackclient:
importance: Undecided → Wishlist
status: New → Confirmed
yanpuqing (ycx) on 2017-05-04
Changed in python-openstackclient:
assignee: nobody → yanpuqing (ycx)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/477728
Committed: https://git.openstack.org/cgit/openstack/python-openstackclient/commit/?id=e7ef9e855677051383446e18e393b1f96158331b
Submitter: Zuul
Branch: master

commit e7ef9e855677051383446e18e393b1f96158331b
Author: ycx <email address hidden>
Date: Tue Jun 27 10:12:06 2017 +0800

    Network: Add interfaces info in router show

    Add a list of interfaces info in the output of
    'openstack router show'.
    The information of router interface are:
    IP address, subnet ID and port ID.

    Co-Authored-By: Dongcan Ye <email address hidden>

    Change-Id: I1252986122122defffe795292b83dc4e84481c7e
    Closes-Bug: #1675489

Changed in python-openstackclient:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-openstackclient 3.13.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers